summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb b/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
index 0a74f5282..e44972178 100644
--- a/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
+++ b/meta-python/recipes-devtools/python/python3-gevent_24.2.1.bb
@@ -4,7 +4,7 @@ a high-level synchronous API on top of the libevent event loop."
4HOMEPAGE = "http://www.gevent.org" 4HOMEPAGE = "http://www.gevent.org"
5LICENSE = "MIT & Python-2.0" 5LICENSE = "MIT & Python-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65" 6LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65"
7DEPENDS += "python3-greenlet libev libuv c-ares python3-cython-native" 7DEPENDS += "python3-greenlet-native python3-greenlet libev libuv python3-cython-native python3-cffi-native"
8 8
9RDEPENDS:${PN} = "python3-greenlet \ 9RDEPENDS:${PN} = "python3-greenlet \
10 python3-mime \ 10 python3-mime \
@@ -18,7 +18,7 @@ SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch \
18 18
19SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056" 19SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056"
20 20
21inherit pypi setuptools3 21inherit pypi python_setuptools_build_meta
22 22
23# Don't embed libraries, link to the system provided libs instead 23# Don't embed libraries, link to the system provided libs instead
24export GEVENTSETUP_EMBED_CARES = "0" 24export GEVENTSETUP_EMBED_CARES = "0"
@@ -36,3 +36,8 @@ do_configure:append() {
36do_compile:append() { 36do_compile:append() {
37 sed -i -e 's#${WORKDIR}##g' ${S}/src/gevent/*.c ${S}/src/gevent/libev/*.c ${S}/src/gevent/resolver/*.c 37 sed -i -e 's#${WORKDIR}##g' ${S}/src/gevent/*.c ${S}/src/gevent/libev/*.c ${S}/src/gevent/resolver/*.c
38} 38}
39
40# http://errors.yoctoproject.org/Errors/Details/766918/
41# src/gevent/queue.c:11894:83: error: passing argument 1 of '__pyx_vtabptr_6gevent_14_gevent_cqueue_UnboundQueue->__pyx_base.put' from incompatible pointer type [-Wincompatible-pointer-types]
42# src/gevent/queue.c:11894:114: error: passing argument 4 of '__pyx_vtabptr_6gevent_14_gevent_cqueue_UnboundQueue->__pyx_base.put' from incompatible pointer type [-Wincompatible-pointer-types]
43CFLAGS += "-Wno-error=incompatible-pointer-types"