summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-gevent_22.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gevent_22.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-gevent_22.8.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gevent_22.8.0.bb b/meta-python/recipes-devtools/python/python3-gevent_22.8.0.bb
new file mode 100644
index 000000000..96a0cb78e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gevent_22.8.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "A coroutine-based Python networking library"
2DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \
3a high-level synchronous API on top of the libevent event loop."
4HOMEPAGE = "http://www.gevent.org"
5LICENSE = "MIT & Python-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65"
7DEPENDS += "${PYTHON_PN}-greenlet libev libuv c-ares python3-cython-native"
8
9RDEPENDS:${PN} = "${PYTHON_PN}-greenlet \
10 ${PYTHON_PN}-mime \
11 ${PYTHON_PN}-pprint \
12 "
13
14SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch"
15
16SRC_URI[sha256sum] = "868d500fe2b7f9750eadc07ada8ab32360c0e71976be2bf5919482f14a6477c7"
17
18inherit pypi setuptools3
19
20# Don't embed libraries, link to the system provided libs instead
21export GEVENTSETUP_EMBED_CARES = "0"
22export GEVENTSETUP_EMBED_LIBEV = "0"
23export GEVENTSETUP_EMBED_LIBUV = "0"
24
25do_configure:append() {
26 # Delete the embedded copies of libraries so we can't accidentally link to them
27 rm -rf ${S}/deps
28
29 # Delete the generated cython files, as they are all out of date with python 3.11
30 rm -rf ${S}/src/gevent/*.c
31}
32
33do_compile:append() {
34 sed -i -e 's#${WORKDIR}##g' ${S}/src/gevent/*.c ${S}/src/gevent/libev/*.c ${S}/src/gevent/resolver/*.c
35}