summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.1.bb b/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.1.bb
new file mode 100644
index 000000000..b13524c22
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.1.bb
@@ -0,0 +1,20 @@
1SUMMARY = "The Real First Universal Charset Detector. Open, modern and actively maintained alternative to Chardet."
2HOMEPAGE = "https://github.com/ousret/charset_normalizer"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=48178f3fc1374ad7e830412f812bde05"
5
6SRC_URI[sha256sum] = "44251f18cd68a75b56585dd00dae26183e102cd5e0f9f1466e6df5da2ed64ea3"
7
8inherit pypi setuptools3
9
10PYPI_PACKAGE = "charset_normalizer"
11UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
12
13RDEPENDS:${PN} += " \
14 python3-core \
15 python3-logging \
16 python3-codecs \
17 python3-json \
18"
19
20BBCLASSEXTEND = "native nativesdk"