summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cantools_39.4.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cantools_39.4.9.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cantools_39.4.9.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cantools_39.4.9.bb b/meta-python/recipes-devtools/python/python3-cantools_39.4.9.bb
new file mode 100644
index 000000000..bf1b4867c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cantools_39.4.9.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "CAN BUS tools in Python 3."
2HOMEPAGE = "https://github.com/eerimoq/cantools"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d9aa4ec07de78abae21c490c9ffe61bd"
5
6SRC_URI[sha256sum] = "5559da0a9b7a0f9e68eb8010b27615f7960be19656f4217374c76993c71f9167"
7
8PYPI_PACKAGE = "cantools"
9
10inherit pypi python_poetry_core
11
12DEPENDS += "python3-setuptools-scm-native"
13
14RDEPENDS:${PN} += "\
15 python3-can \
16 python3-bitstruct \
17 python3-core \
18 python3-textparser \
19 python3-typing-extensions \
20 python3-diskcache \
21 python3-asyncio \
22"
23
24CLEANBROKEN = "1"