summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cachetools_5.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cachetools_5.3.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cachetools_5.3.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cachetools_5.3.3.bb b/meta-python/recipes-devtools/python/python3-cachetools_5.3.3.bb
new file mode 100644
index 000000000..3ef75d470
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cachetools_5.3.3.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Extensible memoizing collections and decorators"
2HOMEPAGE = "https://github.com/tkem/cachetools"
3DESCRIPTION = "This module provides various memoizing \
4collections and decorators, including variants of the \
5Python 3 Standard Library @lru_cache function decorator."
6SECTION = "devel/python"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=539275e657c6b7af026bb908356f7541"
10
11inherit pypi python_setuptools_build_meta ptest
12
13SRC_URI += " \
14 file://run-ptest \
15"
16
17RDEPENDS:${PN} += " \
18 python3-math \
19"
20
21RDEPENDS:${PN}-ptest += " \
22 python3-pytest \
23 python3-unittest-automake-output \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}/tests
28 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}
30
31SRC_URI[sha256sum] = "ba29e2dfa0b8b556606f097407ed1aa62080ee108ab0dc5ec9d6a723a007d105"
32
33BBCLASSEXTEND = "native nativesdk"