summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-bandit_1.7.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bandit_1.7.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-bandit_1.7.8.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bandit_1.7.8.bb b/meta-python/recipes-devtools/python/python3-bandit_1.7.8.bb
new file mode 100644
index 000000000..8b0968857
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bandit_1.7.8.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Security oriented static analyser for python code."
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
4
5SRC_URI[sha256sum] = "36de50f720856ab24a24dbaa5fee2c66050ed97c1477e0a1159deab1775eab6b"
6
7DEPENDS = "python3-pbr-native python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
8
9inherit setuptools3 pypi
10
11RDEPENDS:${PN} += "\
12 python3-git \
13 python3-modules \
14 python3-pbr \
15 python3-pyyaml \
16 python3-rich \
17 python3-six \
18 python3-stevedore \
19 "