summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-argcomplete_3.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-argcomplete_3.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-argcomplete_3.6.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-argcomplete_3.6.0.bb b/meta-python/recipes-devtools/python/python3-argcomplete_3.6.0.bb
new file mode 100644
index 0000000000..f87ca4d925
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-argcomplete_3.6.0.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Argcomplete provides easy, extensible command line tab completion of arguments for your Python script."
2HOMEPAGE = "https://github.com/kislyuk/argcomplete"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=2ee41112a44fe7014dce33e26468ba93"
5
6SRC_URI[sha256sum] = "2e4e42ec0ba2fff54b0d244d0b1623e86057673e57bafe72dda59c64bd5dee8b"
7
8PYPI_PACKAGE = "argcomplete"
9
10inherit pypi python_hatchling
11
12DEPENDS += "python3-hatch-vcs-native"
13
14RDEPENDS:${PN} += "\
15 python3-core \
16 python3-io \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20