summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-argcomplete_2.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-argcomplete_2.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-argcomplete_2.0.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-argcomplete_2.0.0.bb b/meta-python/recipes-devtools/python/python3-argcomplete_2.0.0.bb
new file mode 100644
index 000000000..4eab34f48
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-argcomplete_2.0.0.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Argcomplete provides easy, extensible command line tab completion of arguments for your Python script."
2HOMEPAGE = "https://github.com/kislyuk/argcomplete"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=2ee41112a44fe7014dce33e26468ba93"
5
6SRC_URI[sha256sum] = "6372ad78c89d662035101418ae253668445b391755cfe94ea52f1b9d22425b20"
7
8PYPI_PACKAGE = "argcomplete"
9
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += "\
13 ${PYTHON_PN}-core \
14 ${PYTHON_PN}-io \
15"
16
17BBCLASSEXTEND = "native nativesdk"
18