summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-anyio_4.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-anyio_4.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-anyio_4.4.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-anyio_4.4.0.bb b/meta-python/recipes-devtools/python/python3-anyio_4.4.0.bb
new file mode 100644
index 000000000..28c76cbf5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-anyio_4.4.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "High level compatibility layer for multiple asynchronous event loop implementations"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c0a769411d2af7894099e8ff75058c9f"
5
6inherit pypi python_setuptools_build_meta
7
8SRC_URI[sha256sum] = "5aadc6a1bbb7cdb0bede386cac5e2940f5e2ff3aa20277e991cf028e0585ce94"
9
10DEPENDS += " \
11 python3-setuptools-scm-native \
12"
13
14# Don't provide "trio" PACKAGECONFIG as nothing provides "python3-trio" currently.
15# If somebody needs this please feel free to add python3-trio and enable the
16# packageconfig below:
17#PACKAGECONFIG ??= ""
18#PACKAGECONFIG[trio] = ",,,python3-trio"
19
20RDEPENDS:${PN} += "\
21 python3-idna \
22 python3-sniffio \
23 python3-core \
24 python3-numbers \
25 python3-io \
26 python3-asyncio \
27"