summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-slip-dbus_0.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-slip-dbus_0.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-slip-dbus_0.6.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-slip-dbus_0.6.0.bb b/meta-python/recipes-devtools/python/python-slip-dbus_0.6.0.bb
new file mode 100644
index 000000000..2714f4322
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-slip-dbus_0.6.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Convenience functions for dbus services in Python 2.x"
2HOMEPAGE = "http://nphilipp.fedorapeople.org/python-slip/"
3DESCRIPTION = "\
4The Simple Library for Python 2.x packages contain miscellaneous code for \
5convenience, extension and workaround purposes. \
6\
7This package provides slip.dbus.service.Object, which is a dbus.service.Object \
8derivative that ends itself after a certain time without being used and/or if \
9there are no clients anymore on the message bus, as well as convenience \
10functions and decorators for integrating a dbus service with PolicyKit."
11
12SECTION = "devel/python"
13LICENSE = "GPLv2+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
15SRCNAME = "python-slip"
16
17SRC_URI = "https://fedorahosted.org/released/${SRCNAME}/${SRCNAME}-${PV}.tar.bz2"
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit setuptools
21
22SRC_URI[md5sum] = "fb3299d75af1a67ca6679d96ce839da6"
23SRC_URI[sha256sum] = "f47361ec52b608309b83c71905e692b6b363eaf3b8a7afdeff866cd94463ad5c"
24
25do_compile_prepend() {
26 sed -e 's/@VERSION@/${PV}/g' setup.py.in > setup.py
27}