summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyyaml_3.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyyaml_3.10.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pyyaml_3.10.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyyaml_3.10.bb b/meta-python/recipes-devtools/python/python-pyyaml_3.10.bb
new file mode 100644
index 000000000..100e1c81a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyyaml_3.10.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Python support for YAML"
2HOMEPAGE = "http://www.pyyaml.org"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6015f088759b10e0bc2bf64898d4ae17"
6DEPENDS = "libyaml python-cython-native"
7
8SRC_URI = "http://pyyaml.org/download/pyyaml/PyYAML-${PV}.tar.gz \
9 file://setup.py \
10"
11
12SRC_URI[md5sum] = "74c94a383886519e9e7b3dd1ee540247"
13SRC_URI[sha256sum] = "e713da45c96ca53a3a8b48140d4120374db622df16ab71759c9ceb5b8d46fe7c"
14
15S = "${WORKDIR}/PyYAML-${PV}"
16
17inherit distutils
18
19do_configure_prepend() {
20 # upstream setup.py overcomplicated, use ours
21 install -m 0644 ${WORKDIR}/setup.py ${S}
22}