summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyudev_0.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyudev_0.16.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pyudev_0.16.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyudev_0.16.1.bb b/meta-python/recipes-devtools/python/python-pyudev_0.16.1.bb
new file mode 100644
index 000000000..964b5f92b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyudev_0.16.1.bb
@@ -0,0 +1,25 @@
1SUMMARY = "A libudev binding"
2HOMEPAGE = "http://pypi.python.org/pypi/pyudev"
3SECTION = "devel/python"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
6
7SRCNAME = "pyudev"
8SRC_URI = "http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
9SRC_URI[md5sum] = "4034de584b6d9efcbfc590a047c63285"
10SRC_URI[sha256sum] = "765d1c14bd9bd031f64e2612225621984cb2bbb8cbc0c03538bcc4c735ff1c95"
11
12S = "${WORKDIR}/${SRCNAME}-${PV}"
13
14inherit setuptools
15
16do_configure_prepend() {
17 sed -i "/import pyudev/d" ${S}/setup.py
18 sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
19}
20
21RDEPENDS_${PN} = "\
22 python-ctypes \
23 python-subprocess \
24 python-misc \
25"