summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-m2crypto.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto.inc56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto.inc b/meta-python/recipes-devtools/python/python-m2crypto.inc
new file mode 100644
index 000000000..d0eaa819b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-m2crypto.inc
@@ -0,0 +1,56 @@
1SUMMARY = "A Python crypto and SSL toolkit"
2HOMEPAGE = "https://gitlab.com/m2crypto/m2crypto"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENCE;md5=b0e1f0b7d0ce8a62c18b1287b991800e"
6
7FILESEXTRAPATHS_prepend := "${THISDIR}/python-m2crypto:"
8
9SRC_URI += "file://0001-setup.py-link-in-sysroot-not-in-host-directories.patch \
10 file://cross-compile-platform.patch \
11 file://m2crypto-0.26.4-gcc_macros.patch \
12 "
13SRC_URI[md5sum] = "7fce3cbf85eb84a669682892b935746b"
14SRC_URI[sha256sum] = "a1b2751cdadc6afac3df8a5799676b7b7c67a6ad144bb62d38563062e7cd3fc6"
15
16PYPI_PACKAGE = "M2Crypto"
17inherit pypi siteinfo
18
19DEPENDS += "openssl swig-native"
20RDEPENDS_${PN} += "python-typing"
21
22DISTUTILS_BUILD_ARGS += "build_ext --openssl=${STAGING_DIR_HOST} -I${STAGING_INCDIR}"
23DISTUTILS_INSTALL_ARGS += "build_ext --openssl=${STAGING_DIR_HOST}"
24
25SWIG_FEATURES_x86 = "-D__i386__"
26SWIG_FEATURES ?= "-D__${HOST_ARCH}__"
27export SWIG_FEATURES
28
29# Get around a problem with swig, but only if the
30# multilib header file exists.
31#
32do_configure_prepend() {
33 ${CPP} -dM - < /dev/null | grep -v __STDC__ | grep -v __REGISTER_PREFIX__ | grep -v __GNUC__ \
34 | sed 's/^\(#define \([^ ]*\) .*\)$/#undef \2\n\1/' > SWIG/gcc_macros.h
35 if [ "${SITEINFO_BITS}" = "64" ];then
36 bit="64"
37 else
38 bit="32"
39 fi
40
41 if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then
42 for i in SWIG/_ec.i SWIG/_evp.i; do
43 sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i"
44 done
45 elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then
46 for i in SWIG/_ec.i SWIG/_evp.i; do
47 sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i"
48 done
49 fi
50}
51
52BBCLASSEXTEND = "native"
53
54# http://errors.yoctoproject.org/Errors/Details/184714/
55# SWIG/_m2crypto.i:10: Error: Unable to find 'gcc_macros.h'
56CLEANBROKEN = "1"