summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-lxml_3.4.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-lxml_3.4.4.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb b/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
new file mode 100644
index 000000000..2480e4df9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-lxml_3.4.4.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Python XML bindings for libxml2 and libxslt"
2DESCRIPTION = "Powerful and Pythonic XML processing library combining \
3libxml2/libxslt with the ElementTree API."
4HOMEPAGE = "http://codespeak.net/lxml"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b"
7SRCNAME = "lxml"
8
9DEPENDS = "libxml2 libxslt"
10
11SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "a9a65972afc173ec7a39c585f4eea69c"
14SRC_URI[sha256sum] = "b3d362bac471172747cda3513238f115cbd6c5f8b8e6319bf6a97a7892724099"
15
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18inherit setuptools
19
20DISTUTILS_BUILD_ARGS += " \
21 --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
22 --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
23"
24
25DISTUTILS_INSTALL_ARGS += " \
26 --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
27 --with-xml2-config='${STAGING_BINDIR_CROSS}/pkg-config libxml2' \
28"
29
30BBCLASSEXTEND = "native nativesdk"
31
32RDEPENDS_${PN} += "libxml2 libxslt python-compression"
33RDEPENDS_${PN}_virtclass-native = "libxml2-native libxslt-native"
34