summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-django_1.10.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python-django_1.10.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-django_1.10.5.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-django_1.10.5.bb b/meta-python/recipes-devtools/python/python-django_1.10.5.bb
new file mode 100644
index 000000000..11242df7f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-django_1.10.5.bb
@@ -0,0 +1,24 @@
1SUMMARY = "A high-level Python Web framework"
2HOMEPAGE = "http://www.djangoproject.com/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
5
6SRC_URI[md5sum] = "3fce02f1e6461fec21f1f15ea7489924"
7SRC_URI[sha256sum] = "0db89374b691b9c8b057632a6cd64b18d08db2f4d63b4d4af6024267ab965f8b"
8
9PYPI_PACKAGE = "Django"
10inherit pypi setuptools
11
12FILES_${PN} += "${datadir}/django"
13
14BBCLASSEXTEND = "nativesdk"
15
16RDEPENDS_${PN} += "\
17 ${PYTHON_PN}-datetime \
18 ${PYTHON_PN}-importlib \
19 ${PYTHON_PN}-numbers \
20 ${PYTHON_PN}-pip \
21 ${PYTHON_PN}-pkgutil \
22 ${PYTHON_PN}-subprocess \
23 ${PYTHON_PN}-threading \
24 "