summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-connectivity')
-rw-r--r--meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc12
-rw-r--r--meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb13
-rw-r--r--meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.1.0.bb5
3 files changed, 20 insertions, 10 deletions
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc
new file mode 100644
index 000000000..beb2baf83
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman.inc
@@ -0,0 +1,12 @@
1DESCRIPTION = "Python-based Network Connectivity Management"
2HOMEPAGE = "https://pypi.python.org/pypi/pyconnman/"
3LICENSE = "Apache-2.0"
4
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI[md5sum] = "b7fa82034b1c0e1fb1b518ffe3bb4fc0"
8SRC_URI[sha256sum] = "46c64c0692063fd0c9fb0216d49f7884bec9fa9760d8473db4b1e2f8162fab4a"
9
10inherit pypi
11
12RDEPENDS_${PN} = "connman"
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb
index 77b5e4dcf..3c12db944 100644
--- a/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb
+++ b/meta-python/recipes-connectivity/python-pyconnman/python-pyconnman_0.1.0.bb
@@ -1,12 +1,5 @@
1DESCRIPTION = "Python-based Network Connectivity Management" 1require python-pyconnman.inc
2HOMEPAGE = "https://pypi.python.org/pypi/pyconnman/"
3LICENSE = "Apache-2.0"
4 2
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 3inherit setuptools
6 4
7SRC_URI[md5sum] = "b7fa82034b1c0e1fb1b518ffe3bb4fc0" 5RDEPENDS_${PN} += "python-dbus python-pprint"
8SRC_URI[sha256sum] = "46c64c0692063fd0c9fb0216d49f7884bec9fa9760d8473db4b1e2f8162fab4a"
9
10inherit pypi setuptools
11
12RDEPENDS_${PN} = "connman python-dbus python-pprint"
diff --git a/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.1.0.bb b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.1.0.bb
new file mode 100644
index 000000000..e0f3fdd75
--- /dev/null
+++ b/meta-python/recipes-connectivity/python-pyconnman/python3-pyconnman_0.1.0.bb
@@ -0,0 +1,5 @@
1require python-pyconnman.inc
2
3inherit setuptools3
4
5RDEPENDS_${PN} += "python3-dbus python3-pprint"