diff options
Diffstat (limited to 'meta-perl')
-rw-r--r-- | meta-perl/recipes-perl/libxml/libxml-libxml-perl/0001-libxml-mm-Fix-function-prototypes-in-function-pointe.patch | 51 | ||||
-rw-r--r-- | meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb | 1 |
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libxml/libxml-libxml-perl/0001-libxml-mm-Fix-function-prototypes-in-function-pointe.patch b/meta-perl/recipes-perl/libxml/libxml-libxml-perl/0001-libxml-mm-Fix-function-prototypes-in-function-pointe.patch new file mode 100644 index 000000000..7ff61c570 --- /dev/null +++ b/meta-perl/recipes-perl/libxml/libxml-libxml-perl/0001-libxml-mm-Fix-function-prototypes-in-function-pointe.patch | |||
@@ -0,0 +1,51 @@ | |||
1 | From 25451c0a56ef8d3b32fd23847bef516486bd8ed4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 16 Jan 2023 18:50:10 -0800 | ||
4 | Subject: [PATCH] libxml-mm: Fix function prototypes in function pointers | ||
5 | |||
6 | This is now detected with latest clang16+ | ||
7 | |||
8 | Fixes | ||
9 | error: incompatible function pointer types passing 'void (void *, void *, xmlChar *)' (aka 'void (void *, void *, unsigned char *)') to parameter of type 'xmlHashScanner' (aka 'void (*)(void *, void *, const unsigned char *)') [-Wincompatible-function-pointer-types] | ||
10 | xmlHashScan(r, PmmRegistryDumpHashScanner, NULL); | ||
11 | |||
12 | Upstream-Status: Submitted [https://github.com/shlomif/perl-XML-LibXML/pull/75] | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | perl-libxml-mm.c | 6 +++--- | ||
16 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
17 | |||
18 | diff --git a/perl-libxml-mm.c b/perl-libxml-mm.c | ||
19 | index a3e78a2..ec2b5ea 100644 | ||
20 | --- a/perl-libxml-mm.c | ||
21 | +++ b/perl-libxml-mm.c | ||
22 | @@ -121,7 +121,7 @@ PmmFreeHashTable(xmlHashTablePtr table) | ||
23 | extern SV* PROXY_NODE_REGISTRY_MUTEX; | ||
24 | |||
25 | /* Utility method used by PmmDumpRegistry */ | ||
26 | -void PmmRegistryDumpHashScanner(void * payload, void * data, xmlChar * name) | ||
27 | +void PmmRegistryDumpHashScanner(void * payload, void * data, const xmlChar * name) | ||
28 | { | ||
29 | LocalProxyNodePtr lp = (LocalProxyNodePtr) payload; | ||
30 | ProxyNodePtr node = (ProxyNodePtr) lp->proxy; | ||
31 | @@ -215,7 +215,7 @@ PmmRegisterProxyNode(ProxyNodePtr proxy) | ||
32 | /* PP: originally this was static inline void, but on AIX the compiler | ||
33 | did not chew it, so I'm removing the inline */ | ||
34 | static void | ||
35 | -PmmRegistryHashDeallocator(void *payload, xmlChar *name) | ||
36 | +PmmRegistryHashDeallocator(void *payload, const xmlChar *name) | ||
37 | { | ||
38 | Safefree((LocalProxyNodePtr) payload); | ||
39 | } | ||
40 | @@ -279,7 +279,7 @@ PmmRegistryREFCNT_dec(ProxyNodePtr proxy) | ||
41 | * internal, used by PmmCloneProxyNodes | ||
42 | */ | ||
43 | void * | ||
44 | -PmmRegistryHashCopier(void *payload, xmlChar *name) | ||
45 | +PmmRegistryHashCopier(void *payload, const xmlChar *name) | ||
46 | { | ||
47 | ProxyNodePtr proxy = ((LocalProxyNodePtr) payload)->proxy; | ||
48 | LocalProxyNodePtr lp; | ||
49 | -- | ||
50 | 2.39.0 | ||
51 | |||
diff --git a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb index c2ea47ae5..f184b89e5 100644 --- a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb +++ b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0134.bb | |||
@@ -26,6 +26,7 @@ SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/XML-LibXML-${PV}. | |||
26 | file://disable-libxml2-check.patch \ | 26 | file://disable-libxml2-check.patch \ |
27 | file://fix-CATALOG-conditional-compile.patch \ | 27 | file://fix-CATALOG-conditional-compile.patch \ |
28 | file://using-DOCB-conditional.patch \ | 28 | file://using-DOCB-conditional.patch \ |
29 | file://0001-libxml-mm-Fix-function-prototypes-in-function-pointe.patch \ | ||
29 | " | 30 | " |
30 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=64eda1bc135f0ece1d1187f2a8ac82c1 \ | 31 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=64eda1bc135f0ece1d1187f2a8ac82c1 \ |
31 | file://LICENSE;md5=97871bde150daeb5e61ad95137ff2446 \ | 32 | file://LICENSE;md5=97871bde150daeb5e61ad95137ff2446 \ |