summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0116.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0116.bb')
-rw-r--r--meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0116.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0116.bb b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0116.bb
new file mode 100644
index 000000000..2a6dbc280
--- /dev/null
+++ b/meta-perl/recipes-perl/libxml/libxml-libxml-perl_2.0116.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Perl interface to the libxml2 library"
2DESCRIPTION = "This module is an interface to libxml2, providing XML and HTML parsers \
3with DOM, SAX and XMLReader interfaces, a large subset of DOM Layer 3 \
4interface and a XML::XPath-like interface to XPath API of libxml2. \
5The module is split into several packages which are not described in this \
6section; unless stated otherwise, you only need to use XML::LibXML; in \
7your programs."
8
9HOMEPAGE = "http://search.cpan.org/dist/XML-LibXML-1.99/"
10SECTION = "libs"
11LICENSE = "Artistic-1.0|GPLv1+"
12DEPENDS += "libxml2 \
13 libxml-sax-perl-native \
14 zlib \
15"
16RDEPENDS_${PN} += "libxml2 \
17 libxml-sax-perl \
18 libxml-sax-base-perl \
19 zlib \
20"
21
22SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/XML-LibXML-${PV}.tar.gz;name=libxml \
23 file://disable-libxml2-check.patch \
24 file://fix-CATALOG-conditional-compile.patch \
25 file://using-DOCB-conditional.patch \
26"
27LIC_FILES_CHKSUM = "file://debian/copyright;md5=75e021e35a906347f46c9ff163653e2a \
28 file://LICENSE;md5=97871bde150daeb5e61ad95137ff2446"
29SRC_URI[libxml.md5sum] = "a53a743bf053a0cb4afb41513fb8a684"
30SRC_URI[libxml.sha256sum] = "b154f2dad3033b30d22ac81b8985b69ad35450b0c552db394cd03bb36845812a"
31
32S = "${WORKDIR}/XML-LibXML-${PV}"
33
34inherit cpan
35
36EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}"
37
38BBCLASSEXTEND = "native"
39
40CFLAGS += " -D_GNU_SOURCE "
41BUILD_CFLAGS += " -D_GNU_SOURCE "
42
43do_configure_prepend() {
44 rm -rf ${S}/.pc/*
45}
46
47FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/"