summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.65.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.65.bb')
-rw-r--r--meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.65.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.65.bb b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.65.bb
new file mode 100644
index 000000000..f6c4b8b36
--- /dev/null
+++ b/meta-perl/recipes-perl/libnet/libnet-ssleay-perl_1.65.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Net::SSLeay - Perl extension for using OpenSSL"
2DESCRIPTION = "This module offers some high level convenience functions for accessing \
3web pages on SSL servers (for symmetry, same API is offered for \
4accessing http servers, too), a sslcat() function for writing your own \
5clients, and finally access to the SSL api of SSLeay/OpenSSL package \
6so you can write servers or clients for more complicated applications."
7HOMEPAGE = "http://search.cpan.org/dist/Net-SSLeay/"
8SECTION = "libs"
9
10LICENSE = "OpenSSL"
11LIC_FILES_CHKSUM = "file://README;beginline=274;endline=294;md5=49f415984b387be999ee2ad0e5c692fe"
12
13DEPENDS = "openssl zlib"
14RDEPENDS_${PN} += "perl-module-carp \
15 perl-module-errno \
16 perl-module-extutils-makemaker \
17 perl-module-mime-base64 \
18 perl-module-socket \
19 "
20
21SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \
22 file://run-ptest \
23 "
24SRC_URI[md5sum] = "19600c036e9e0bbfbf9157f083e40755"
25SRC_URI[sha256sum] = "2fb1371120b85f018944d95736c107163f04ba56b6029c0709a2c3d6247b9c06"
26
27S = "${WORKDIR}/Net-SSLeay-${PV}"
28
29inherit cpan ptest
30
31EXTRA_CPANFLAGS = "LIBS='-L=${STAGING_LIBDIR} -L=${STAGING_BASELIBDIR}' \
32 INC=-I=${STAGING_INCDIR} \
33 'EXTRALIBS=-lssl -lcrypto -lz' \
34 'LDLOADLIBS=-lssl -lcrypto -lz' \
35 "
36
37do_configure_prepend() {
38 export OPENSSL_PREFIX=${STAGING_DIR_NATIVE}${prefix_native}
39}
40
41do_install_ptest() {
42 cp -r ${B}/t ${D}${PTEST_PATH}
43}
44
45BBCLASSEXTEND = "native"
46
47FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Net/SSLeay/.debug/"