summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.1.bb')
-rw-r--r--meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.1.bb b/meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.1.bb
new file mode 100644
index 000000000..b91691807
--- /dev/null
+++ b/meta-perl/recipes-perl/libmodule/libmodule-pluggable-perl_5.1.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Automatically give your module the ability to have plugins"
2DESCRIPTION = "Provides a simple but, hopefully, extensible way of \
3having 'plugins' for your module. Obviously this isn't going to be the \
4be all and end all of solutions but it works for me.\
5\
6Essentially all it does is export a method into your namespace that \
7looks through a search path for .pm files and turn those into class \
8names.\
9\
10Optionally it instantiates those classes for you."
11SECTION = "libs"
12
13AUTHOR = "Simon Wistow <simon@thegestalt.org>"
14HOMEPAGE = "https://github.com/simonwistow/Module-Pluggable"
15
16LICENSE = "Artistic-1.0 | GPL-1.0+"
17LIC_FILES_CHKSUM = "file://README;beginline=322;endline=325;md5=086450ce010f6fda25db0b38fcc41086"
18
19SRCNAME = "Module-Pluggable"
20SRC_URI = "${CPAN_MIRROR}/authors/id/S/SI/SIMONW/${SRCNAME}-${PV}.tar.gz"
21SRC_URI[md5sum] = "1b71ed7a67ad8c048d1499540bc892ba"
22SRC_URI[sha256sum] = "e2dc354043bb16f1f3df8c4bb26070b26e594819f218cf8b8ac19e79c720916f"
23
24S = "${WORKDIR}/${SRCNAME}-${PV}"
25
26inherit cpan_build
27
28RDEPENDS_${PN} = " perl-module-base \
29 perl-module-deprecate \
30 perl-module-file-basename \
31 perl-module-file-find \
32 perl-module-file-spec \
33 perl-module-file-spec-functions \
34 perl-module-if \
35 perl-module-test-more \
36"
37
38BBCLASSEXTEND = "native"
39