summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_1.997.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libio/libio-socket-ssl-perl_1.997.bb')
-rw-r--r--meta-perl/recipes-perl/libio/libio-socket-ssl-perl_1.997.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_1.997.bb b/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_1.997.bb
new file mode 100644
index 000000000..19dec83a5
--- /dev/null
+++ b/meta-perl/recipes-perl/libio/libio-socket-ssl-perl_1.997.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Perl library for transparent SSL"
2DESCRIPTION = "This module is a true drop-in replacement for IO::Socket::INET that \
3uses SSL to encrypt data before it is transferred to a remote server \
4or client. IO::Socket::SSL supports all the extra features that one \
5needs to write a full-featured SSL client or server application: \
6multiple SSL contexts, cipher selection, certificate verification, and \
7SSL version selection. As an extra bonus, it works perfectly with \
8mod_perl."
9HOMEPAGE = "http://search.cpan.org/dist/IO-Socket-SSL/"
10SECTION = "libs"
11
12LICENSE = "Artistic-1.0|GPLv1+"
13LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8"
14
15RDEPENDS_${PN} += "perl-module-scalar-util libnet-ssleay-perl"
16
17SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SU/SULLR/IO-Socket-SSL-${PV}.tar.gz \
18 file://run-ptest \
19 "
20SRC_URI[md5sum] = "2a6268bb42da81e69d1c1feb2fcb0eea"
21SRC_URI[sha256sum] = "acdb67b5b63aea5b7e70c3e4c70a16128810329592b63753a38c794aff76a1dd"
22
23S = "${WORKDIR}/IO-Socket-SSL-${PV}"
24
25inherit cpan ptest
26
27PACKAGE_ARCH = "all"
28
29do_install_append () {
30 mkdir -p ${D}${docdir}/${PN}/
31 cp ${S}/BUGS ${D}${docdir}/${PN}/
32 cp ${S}/Changes ${D}${docdir}/${PN}/
33 cp ${S}/README ${D}${docdir}/${PN}/
34 cp -pRP ${S}/docs ${D}${docdir}/${PN}/
35 cp -pRP ${S}/certs ${D}${docdir}/${PN}/
36 cp -pRP ${S}/example ${D}${docdir}/${PN}/
37 cp -pRP ${S}/util ${D}${docdir}/${PN}/
38}
39
40do_install_ptest () {
41 cp -r ${B}/t ${D}${PTEST_PATH}
42 cp -r ${B}/certs ${D}${PTEST_PATH}
43}
44
45BBCLASSEXTEND = "native"