summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb')
-rw-r--r--meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb b/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb
new file mode 100644
index 000000000..99df6f33f
--- /dev/null
+++ b/meta-perl/recipes-perl/libextutils/libextutils-cppguess-perl_0.12.bb
@@ -0,0 +1,37 @@
1SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags"
2DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \
3compiler that is compatible with the C compiler that your perl was built \
4with. \
5It can generate the necessary options to the Module::Build constructor or \
6to ExtUtils::MakeMaker's WriteMakefile function."
7SECTION = "libs"
8
9HOMEPAGE = "http://search.cpan.org/~smueller/ExtUtils-CppGuess/"
10
11LICENSE = "Artistic-1.0 | GPL-1.0+"
12LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETJ/ExtUtils-CppGuess-${PV}.tar.gz"
15SRC_URI[md5sum] = "28be49072585b25df87e54180f741a4d"
16SRC_URI[sha256sum] = "31c47b5b15e3e9fd5ae7b35881a0fffd26a2983b241e7e3a1bc340d6d446186b"
17
18S = "${WORKDIR}/ExtUtils-CppGuess-${PV}"
19
20inherit cpan
21
22do_install () {
23 cpan_do_install
24}
25
26RDEPENDS_${PN} = " libcapture-tiny-perl \
27 perl-module-scalar-util \
28 perl-module-io-file \
29 perl-module-extutils-makemaker \
30 perl-module-file-spec \
31 perl-module-exporter \
32 perl-module-carp \
33 perl-module-file-temp \
34 perl-module-lib \
35"
36
37BBCLASSEXTEND = "native"