summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libdigest/libdigest-sha1-perl_2.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libdigest/libdigest-sha1-perl_2.13.bb')
-rw-r--r--meta-perl/recipes-perl/libdigest/libdigest-sha1-perl_2.13.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libdigest/libdigest-sha1-perl_2.13.bb b/meta-perl/recipes-perl/libdigest/libdigest-sha1-perl_2.13.bb
new file mode 100644
index 000000000..0371ea68c
--- /dev/null
+++ b/meta-perl/recipes-perl/libdigest/libdigest-sha1-perl_2.13.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Perl interface to the SHA-1 algorithm "
2DESCRIPTION = "Digest::SHA1 - Perl interface to the SHA-1 algorithm"
3HOMEPAGE = "http://search.cpan.org/~gaas/Digest-SHA1-2.13/"
4SECTION = "libs"
5
6LICENSE = "Artistic-1.0|GPLv1+"
7LIC_FILES_CHKSUM = "file://README;beginline=10;endline=14;md5=ff5867ebb4bc1103a7a416aef2fce00a"
8
9SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/Digest-SHA1-${PV}.tar.gz \
10 file://run-ptest \
11 "
12SRC_URI[md5sum] = "bd22388f268434f2b24f64e28bf1aa35"
13SRC_URI[sha256sum] = "68c1dac2187421f0eb7abf71452a06f190181b8fc4b28ededf5b90296fb943cc"
14
15S = "${WORKDIR}/Digest-SHA1-${PV}"
16
17inherit cpan ptest
18
19do_install_ptest () {
20 cp -r ${B}/t ${D}${PTEST_PATH}
21}
22
23BBCLASSEXTEND="native"
24
25FILES_${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Digest/SHA1/.debug/"