summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libdb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libdb')
-rw-r--r--meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.62.bb (renamed from meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.54.bb)43
1 files changed, 29 insertions, 14 deletions
diff --git a/meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.54.bb b/meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.62.bb
index c72e536de..4af9d3c5c 100644
--- a/meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.54.bb
+++ b/meta-perl/recipes-perl/libdb/libdbd-sqlite-perl_1.62.bb
@@ -4,34 +4,33 @@ thing in the distribution. So in order to get a fast transaction capable \
4RDBMS working for your perl project you simply have to install this \ 4RDBMS working for your perl project you simply have to install this \
5module, and nothing else. \ 5module, and nothing else. \
6" 6"
7HOMEPAGE = "http://search.cpan.org/~ishigaki/DBD-SQLite/" 7HOMEPAGE = "https://metacpan.org/release/DBD-SQLite"
8 8
9SECTION = "libs" 9SECTION = "libs"
10LICENSE = "Artistic-1.0 | GPL-1.0+" 10LICENSE = "Artistic-1.0 | GPL-1.0+"
11DEPENDS += "libdbi-perl-native"
12RDEPENDS_${PN} += "libdbi-perl \
13 sqlite3 \
14 perl-module-constant \
15 perl-module-locale \
16 perl-module-tie-hash \
17"
18
19LIC_FILES_CHKSUM = "file://LICENSE;md5=1726e2117494ba3e13e1c3d93f795360" 11LIC_FILES_CHKSUM = "file://LICENSE;md5=1726e2117494ba3e13e1c3d93f795360"
20 12
21SRC_URI = "http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/DBD-SQLite-${PV}.tar.gz \ 13SRC_URI = "${CPAN_MIRROR}/authors/id/I/IS/ISHIGAKI/DBD-SQLite-${PV}.tar.gz \
22 file://sqlite-perl-test.pl \ 14 file://sqlite-perl-test.pl \
23" 15"
24 16
25SRC_URI[md5sum] = "8f835ddacb9a4a92a52bbe2d24d18a8e" 17SRC_URI[md5sum] = "f2e11a2bea6bd864404c0363d7eddaf8"
26SRC_URI[sha256sum] = "3929a6dbd8d71630f0cb57f85dcef9588cd7ac4c9fa12db79df77b9d3a4d7269" 18SRC_URI[sha256sum] = "bd82ef322a9e5469a7a62d845c32fad1188b76ccb49a88520cec768343cce85c"
27 19
28UPSTREAM_CHECK_REGEX = "DBD\-SQLite\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" 20UPSTREAM_CHECK_REGEX = "DBD\-SQLite\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
29 21
30S = "${WORKDIR}/DBD-SQLite-${PV}" 22S = "${WORKDIR}/DBD-SQLite-${PV}"
31 23
32inherit cpan 24DEPENDS += "libdbi-perl-native"
33 25
34BBCLASSEXTEND = "native" 26inherit cpan ptest-perl
27
28RDEPENDS_${PN} += "libdbi-perl \
29 sqlite3 \
30 perl-module-constant \
31 perl-module-locale \
32 perl-module-tie-hash \
33"
35 34
36do_install_append() { 35do_install_append() {
37 if [ ${PERL_DBM_TEST} = "1" ]; then 36 if [ ${PERL_DBM_TEST} = "1" ]; then
@@ -39,3 +38,19 @@ do_install_append() {
39 fi 38 fi
40} 39}
41 40
41do_install_ptest() {
42 cp -r ${B}/MANIFEST ${D}${PTEST_PATH}
43 chown -R root:root ${D}${PTEST_PATH}
44}
45
46RDEPENDS_${PN}-ptest += " \
47 libtest-nowarnings-perl \
48 perl-module-lib \
49 perl-module-encode \
50 perl-module-file-spec \
51 perl-module-file-spec-functions \
52 perl-module-findbin \
53 perl-module-test-more \
54 "
55
56BBCLASSEXTEND = "native"