summaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.28.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.28.bb')
-rw-r--r--meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.28.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.28.bb b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.28.bb
new file mode 100644
index 000000000..f0c610f3a
--- /dev/null
+++ b/meta-perl/recipes-perl/libcrypt/libcrypt-openssl-rsa-perl_0.28.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Crypt Openssl RSA cpan module"
2SECTION = "libs"
3LICENSE = "Artistic-1.0 | GPL-1.0+"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=385c55653886acac3821999a3ccd17b3"
5
6SRC_URI = "http://www.cpan.org/modules/by-module/Crypt/Crypt-OpenSSL-RSA-${PV}.tar.gz "
7
8SRC_URI[md5sum] = "86217a5036fc63779c30420b5fd84129"
9SRC_URI[sha256sum] = "5357f977464bb3a8184cf2d3341851a10d5515b4b2b0dfb88bf78995c0ded7be"
10
11DEPENDS += "openssl"
12
13RDEPENDS_${PN}="libcrypt-openssl-random-perl"
14
15EXTRA_CPANFLAGS = "INC='-I${STAGING_INCDIR}' LIBS='-L${STAGING_LIBDIR} -lssl -L${STAGING_DIR_TARGET}${base_libdir} -lcrypto'"
16
17S = "${WORKDIR}/Crypt-OpenSSL-RSA-${PV}"
18
19inherit cpan
20
21do_compile() {
22 export OTHERLDFLAGS='-Wl,-rpath'
23 cpan_do_compile
24}