diff options
Diffstat (limited to 'meta-oe')
3 files changed, 110 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-fix-compile-failure-against-musl-C-library.patch b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-fix-compile-failure-against-musl-C-library.patch new file mode 100644 index 0000000000..234d696f19 --- /dev/null +++ b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0001-fix-compile-failure-against-musl-C-library.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | From 950b27f8320b841490cafcb3e6e3b818c7174c0d Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Thu, 20 Jul 2017 22:32:50 -0400 | ||
4 | Subject: [PATCH] fix compile failure against musl C library | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
9 | --- | ||
10 | test/cpp/server_abyss.cpp | 2 +- | ||
11 | tools/xmlrpc_pstream/xmlrpc_pstream.cpp | 10 +++++++--- | ||
12 | 2 files changed, 8 insertions(+), 4 deletions(-) | ||
13 | |||
14 | diff --git a/test/cpp/server_abyss.cpp b/test/cpp/server_abyss.cpp | ||
15 | index 2458a8f..82f91da 100644 | ||
16 | --- a/test/cpp/server_abyss.cpp | ||
17 | +++ b/test/cpp/server_abyss.cpp | ||
18 | @@ -18,7 +18,7 @@ | ||
19 | #ifdef WIN32 | ||
20 | #include <winsock2.h> | ||
21 | #else | ||
22 | - #include <sys/unistd.h> | ||
23 | + #include <unistd.h> | ||
24 | #include <sys/socket.h> | ||
25 | #include <arpa/inet.h> | ||
26 | #include <netinet/in.h> | ||
27 | diff --git a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp b/tools/xmlrpc_pstream/xmlrpc_pstream.cpp | ||
28 | index d39e105..1fd8900 100644 | ||
29 | --- a/tools/xmlrpc_pstream/xmlrpc_pstream.cpp | ||
30 | +++ b/tools/xmlrpc_pstream/xmlrpc_pstream.cpp | ||
31 | @@ -15,11 +15,15 @@ | ||
32 | #include "xmlrpc-c/girerr.hpp" | ||
33 | using girerr::throwf; | ||
34 | |||
35 | -#include <features.h> // for __BEGIN_DECLS | ||
36 | +#ifdef __cplusplus | ||
37 | +extern "C" { | ||
38 | +#endif | ||
39 | |||
40 | -__BEGIN_DECLS | ||
41 | #include "dumpvalue.h" /* An internal Xmlrpc-c header file ! */ | ||
42 | -__END_DECLS | ||
43 | + | ||
44 | +#ifdef __cplusplus | ||
45 | +} | ||
46 | +#endif | ||
47 | |||
48 | |||
49 | #include <xmlrpc-c/base.hpp> | ||
50 | -- | ||
51 | 2.8.1 | ||
52 | |||
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0002-fix-formatting-issues.patch b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0002-fix-formatting-issues.patch new file mode 100644 index 0000000000..9d92e4712b --- /dev/null +++ b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c/0002-fix-formatting-issues.patch | |||
@@ -0,0 +1,34 @@ | |||
1 | From 14f15cb0f03defa8efb4c8e2fece58e50655be6b Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Sun, 23 Jul 2017 22:20:29 -0400 | ||
4 | Subject: [PATCH] src/xmlrpc_server_abyss.c: fix formatting issues | ||
5 | |||
6 | Fixed when compile with "-Wformat -Wformat-security -Werror=format-security": | ||
7 | |src/xmlrpc_server_abyss.c:771:13: error: format not a string literal | ||
8 | and no format arguments [-Werror=format-security] | ||
9 | | xmlrpc_faultf(envP, error); | ||
10 | | ^~~~~~~~~~~~~ | ||
11 | |||
12 | Upstream-Status: Pending | ||
13 | |||
14 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
15 | --- | ||
16 | src/xmlrpc_server_abyss.c | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/src/xmlrpc_server_abyss.c b/src/xmlrpc_server_abyss.c | ||
20 | index 2388652..3843f10 100644 | ||
21 | --- a/src/xmlrpc_server_abyss.c | ||
22 | +++ b/src/xmlrpc_server_abyss.c | ||
23 | @@ -768,7 +768,7 @@ createServer(xmlrpc_env * const envP, | ||
24 | ServerInit2(abyssServerP, &error); | ||
25 | |||
26 | if (error) { | ||
27 | - xmlrpc_faultf(envP, error); | ||
28 | + xmlrpc_faultf(envP, "%s", error); | ||
29 | xmlrpc_strfree(error); | ||
30 | } | ||
31 | } | ||
32 | -- | ||
33 | 2.8.1 | ||
34 | |||
diff --git a/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.31.0.bb b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.31.0.bb new file mode 100644 index 0000000000..70bd9e87ea --- /dev/null +++ b/meta-oe/recipes-devtools/xmlrpc-c/xmlrpc-c_1.31.0.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to help you \ | ||
2 | write an XML-RPC server or client in C or C++." | ||
3 | |||
4 | HOMEPAGE = "http://xmlrpc-c.sourceforge.net/" | ||
5 | LICENSE = "BSD & MIT" | ||
6 | LIC_FILES_CHKSUM = "file://doc/COPYING;md5=aefbf81ba0750f02176b6f86752ea951" | ||
7 | |||
8 | SRC_URI = "git://github.com/ensc/xmlrpc-c.git;branch=master \ | ||
9 | file://0001-fix-compile-failure-against-musl-C-library.patch \ | ||
10 | file://0002-fix-formatting-issues.patch \ | ||
11 | " | ||
12 | SRCREV = "81443a9dc234cc275449dbc17867ad77ae189124" | ||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | DEPENDS = "curl libxml2" | ||
16 | RDEPENDS_${PN} = "curl" | ||
17 | |||
18 | inherit cmake | ||
19 | |||
20 | EXTRA_OECMAKE = "-D_lib:STRING=${baselib}" | ||
21 | |||
22 | BBCLASSEXTEND = "native" | ||
23 | |||
24 | TARGET_CFLAGS += "-Wno-narrowing" | ||