diff options
Diffstat (limited to 'meta-oe')
6 files changed, 199 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/configure.patch b/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/configure.patch new file mode 100644 index 000000000..ea13e11d2 --- /dev/null +++ b/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/configure.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- liblockfile-1.05/./configure.in~configure | ||
7 | +++ liblockfile-1.05/./configure.in | ||
8 | @@ -1,4 +1,5 @@ | ||
9 | -AC_INIT(lockfile.c) | ||
10 | +AC_INIT | ||
11 | +AC_CONFIG_SRCDIR([lockfile.c]) | ||
12 | AC_CONFIG_HEADER(autoconf.h) | ||
13 | AC_REVISION($Revision: 1.0 $)dnl | ||
14 | |||
15 | @@ -111,7 +112,8 @@ | ||
16 | AC_SUBST(INSTALL_TARGETS) | ||
17 | AC_SUBST(nfslockdir) | ||
18 | |||
19 | -AC_OUTPUT(\ | ||
20 | +AC_CONFIG_FILES([\ | ||
21 | ./Makefile \ | ||
22 | ./maillock.h \ | ||
23 | -) | ||
24 | +]) | ||
25 | +AC_OUTPUT | ||
diff --git a/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/glibc-2.4.patch b/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/glibc-2.4.patch new file mode 100644 index 000000000..e3c4aaae5 --- /dev/null +++ b/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/glibc-2.4.patch | |||
@@ -0,0 +1,70 @@ | |||
1 | The local function eaccess conflicts with a glibc function of the same name. | ||
2 | Rename the function so that this can be build under glibc 2.4, and older | ||
3 | revisions, without any problems. | ||
4 | |||
5 | --- liblockfile-1.06/dotlockfile.c 2006/07/10 03:17:40 1.1 | ||
6 | +++ liblockfile-1.06/dotlockfile.c 2006/07/10 03:18:26 | ||
7 | @@ -42,7 +42,7 @@ | ||
8 | extern int optind; | ||
9 | #endif | ||
10 | |||
11 | -extern int eaccess(char *, gid_t, struct stat *); | ||
12 | +extern int xeaccess(char *, gid_t, struct stat *); | ||
13 | |||
14 | /* | ||
15 | * Sleep for an amout of time while regulary checking if | ||
16 | @@ -252,14 +252,14 @@ | ||
17 | return L_ERROR; | ||
18 | } | ||
19 | gid = getgid(); | ||
20 | - if (eaccess(dir, gid, &st) < 0) { | ||
21 | + if (xeaccess(dir, gid, &st) < 0) { | ||
22 | if (errno == ENOENT) { | ||
23 | enoent: | ||
24 | if (!quiet) fprintf(stderr, | ||
25 | "dotlockfile: %s: no such directory\n", dir); | ||
26 | return L_TMPLOCK; | ||
27 | } | ||
28 | - if ((r = eaccess(dir, getegid(), &st) < 0) && errno == ENOENT) | ||
29 | + if ((r = xeaccess(dir, getegid(), &st) < 0) && errno == ENOENT) | ||
30 | goto enoent; | ||
31 | if (r < 0 || !ismaillock(lockfile, pwd->pw_name)) { | ||
32 | if (!quiet) fprintf(stderr, | ||
33 | @@ -272,7 +272,7 @@ | ||
34 | /* | ||
35 | * Now we should be able to chdir() to the lock directory. | ||
36 | * When we stat("."), it should be the same as at the | ||
37 | - * eaccess() check or someone played symlink() games on us. | ||
38 | + * xeaccess() check or someone played symlink() games on us. | ||
39 | */ | ||
40 | if (chdir(dir) < 0 || stat(".", &st2) < 0) { | ||
41 | if (!quiet) fprintf(stderr, | ||
42 | --- liblockfile-1.06/lockfile.c 2006/07/10 03:17:40 1.1 | ||
43 | +++ liblockfile-1.06/lockfile.c 2006/07/10 03:18:26 | ||
44 | @@ -54,7 +54,7 @@ | ||
45 | #ifdef LIB | ||
46 | static | ||
47 | #endif | ||
48 | -int eaccess(char *fn, gid_t gid, struct stat *st) | ||
49 | +int xeaccess(char *fn, gid_t gid, struct stat *st) | ||
50 | { | ||
51 | struct stat tmp; | ||
52 | uid_t uid = geteuid(); | ||
53 | @@ -96,7 +96,7 @@ | ||
54 | *p = 0; | ||
55 | else | ||
56 | strcpy(dir, "."); | ||
57 | - if (eaccess(dir, egid, NULL) >= 0) { | ||
58 | + if (xeaccess(dir, egid, NULL) >= 0) { | ||
59 | free(dir); | ||
60 | return 0; | ||
61 | } | ||
62 | @@ -111,7 +111,7 @@ | ||
63 | return 0; | ||
64 | mailgid = st.st_gid; | ||
65 | } | ||
66 | - ret = eaccess(dir, mailgid, NULL) >= 0; | ||
67 | + ret = xeaccess(dir, mailgid, NULL) >= 0; | ||
68 | free (dir); | ||
69 | return ret; | ||
70 | } | ||
diff --git a/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/install.patch b/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/install.patch new file mode 100644 index 000000000..a9319ff1e --- /dev/null +++ b/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/install.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- liblockfile-1.05/Makefile.in~install | ||
7 | +++ liblockfile-1.05/Makefile.in | ||
8 | @@ -20,6 +20,7 @@ | ||
9 | includedir = @includedir@ | ||
10 | |||
11 | MAILGROUP = @MAILGROUP@ | ||
12 | +INSTGRP = $(if $(MAILGROUP),-g $(MAILGROUP)) | ||
13 | |||
14 | all: @TARGETS@ | ||
15 | install: @INSTALL_TARGETS@ | ||
16 | @@ -50,25 +51,27 @@ | ||
17 | $(CC) $(CFLAGS) -c lockfile.c -o xlockfile.o | ||
18 | |||
19 | install_static: static install_common | ||
20 | + install -d $(ROOT)$(libdir) | ||
21 | install -m 644 liblockfile.a $(ROOT)$(libdir) | ||
22 | |||
23 | install_shared: shared install_common | ||
24 | + install -d $(ROOT)$(libdir) | ||
25 | install -m 755 liblockfile.so \ | ||
26 | $(ROOT)$(libdir)/liblockfile.so.$(VER) | ||
27 | ln -s liblockfile.so.$(VER) $(ROOT)$(libdir)/liblockfile.so | ||
28 | if test "$(ROOT)" = ""; then @LDCONFIG@; fi | ||
29 | |||
30 | install_common: | ||
31 | + install -d $(ROOT)$(includedir) | ||
32 | install -m 644 lockfile.h maillock.h $(ROOT)$(includedir) | ||
33 | - if [ "$(MAILGROUP)" != "" ]; then\ | ||
34 | - install -g $(MAILGROUP) -m 2755 dotlockfile $(ROOT)$(bindir);\ | ||
35 | - else \ | ||
36 | - install -g root -m 755 dotlockfile $(ROOT)$(bindir); \ | ||
37 | - fi | ||
38 | + install -d $(ROOT)$(bindir) | ||
39 | + install -m 755 $(INSTGRP) dotlockfile $(ROOT)$(bindir) | ||
40 | + install -d $(ROOT)$(mandir)/man1 $(ROOT)$(mandir)/man3 | ||
41 | install -m 644 *.1 $(ROOT)$(mandir)/man1 | ||
42 | install -m 644 *.3 $(ROOT)$(mandir)/man3 | ||
43 | |||
44 | install_nfslib: nfslib | ||
45 | + install -d $(ROOT)$(nfslockdir) | ||
46 | install -m 755 nfslock.so.$(VER) $(ROOT)$(nfslockdir) | ||
47 | if test "$(ROOT)" = ""; then @LDCONFIG@; fi | ||
48 | |||
diff --git a/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/ldflags.patch b/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/ldflags.patch new file mode 100644 index 000000000..eb1d1478b --- /dev/null +++ b/meta-oe/recipes-extended/liblockfile/liblockfile-1.06/ldflags.patch | |||
@@ -0,0 +1,21 @@ | |||
1 | |||
2 | # | ||
3 | # Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher | ||
4 | # | ||
5 | |||
6 | --- liblockfile-1.05/Makefile.in~ldflags | ||
7 | +++ liblockfile-1.05/Makefile.in | ||
8 | @@ -34,11 +34,11 @@ | ||
9 | |||
10 | liblockfile.so: liblockfile.a | ||
11 | $(CC) -fPIC -shared -Wl,-soname,liblockfile.so.1 \ | ||
12 | - -o liblockfile.so lockfile.o -lc | ||
13 | + -o liblockfile.so lockfile.o $(LDFLAGS) -lc | ||
14 | |||
15 | nfslock.so.$(VER): nfslock.o | ||
16 | $(CC) -fPIC -shared -Wl,-soname,nfslock.so.0 \ | ||
17 | - -o nfslock.so.$(NVER) nfslock.o | ||
18 | + -o nfslock.so.$(NVER) nfslock.o $(LDFLAGS) | ||
19 | |||
20 | dotlockfile: dotlockfile.o xlockfile.o | ||
21 | $(CC) $(LDFLAGS) -o dotlockfile dotlockfile.o xlockfile.o | ||
diff --git a/meta-oe/recipes-extended/liblockfile/liblockfile_1.06.bb b/meta-oe/recipes-extended/liblockfile/liblockfile_1.06.bb new file mode 100644 index 000000000..971eff184 --- /dev/null +++ b/meta-oe/recipes-extended/liblockfile/liblockfile_1.06.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | DESCRIPTION = "File locking library." | ||
2 | SECTION = "libs" | ||
3 | LICENSE = "LGPLv2+ & GPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35127b30003a121544b5d13a2ac868b6" | ||
5 | |||
6 | SRC_URI = "http://snapshot.debian.org/archive/debian/20050312T000000Z/pool/main/libl/liblockfile/liblockfile_${PV}.tar.gz \ | ||
7 | file://install.patch \ | ||
8 | file://configure.patch \ | ||
9 | file://ldflags.patch \ | ||
10 | file://glibc-2.4.patch" | ||
11 | |||
12 | inherit autotools | ||
13 | |||
14 | EXTRA_OECONF = "--enable-shared --enable-static" | ||
15 | |||
16 | do_install () { | ||
17 | oe_runmake 'ROOT=${D}' INSTGRP='' install | ||
18 | } | ||
19 | |||
20 | SRC_URI[md5sum] = "2de88389da013488bfd31356523070c0" | ||
21 | SRC_URI[sha256sum] = "14f9690328318d11f9ba13a9356a2c008bdd169b7a817f38cb7f9eb32cf7240e" | ||
diff --git a/meta-oe/recipes-extended/libungif/libungif_4.1.3.bb b/meta-oe/recipes-extended/libungif/libungif_4.1.3.bb new file mode 100644 index 000000000..0e9bf9b87 --- /dev/null +++ b/meta-oe/recipes-extended/libungif/libungif_4.1.3.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | DESCRIPTION = "shared library for GIF images" | ||
2 | SECTION = "libs" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=ae11c61b04b2917be39b11f78d71519a" | ||
5 | |||
6 | SRC_URI = "${SOURCEFORGE_MIRROR}/giflib/libungif-${PV}.tar.bz2" | ||
7 | SRC_URI[md5sum] = "8c198831cc0495596c78134b8849e9ad" | ||
8 | SRC_URI[sha256sum] = "59e835a57e6df03e4d2253b2357253f3d13da9473ff465563a3b9833a744fc36" | ||
9 | |||
10 | inherit autotools lib_package | ||
11 | |||
12 | PACKAGES =+ "${PN}-utils" | ||
13 | |||
14 | FILES_${PN}-utils = "${bindir}/*" | ||