summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/enca/enca/configure-hack.patch12
-rw-r--r--meta-oe/recipes-support/enca/enca/configure-remove-dumbness.patch26
-rw-r--r--meta-oe/recipes-support/enca/enca/dont-run-tests.patch13
-rw-r--r--meta-oe/recipes-support/enca/enca/makefile-remove-tools.patch13
-rw-r--r--meta-oe/recipes-support/enca/enca_1.9.bb36
5 files changed, 100 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/enca/enca/configure-hack.patch b/meta-oe/recipes-support/enca/enca/configure-hack.patch
new file mode 100644
index 000000000..85abcdcf0
--- /dev/null
+++ b/meta-oe/recipes-support/enca/enca/configure-hack.patch
@@ -0,0 +1,12 @@
1--- enca-1.9/configure.ac.orig 2006-02-15 00:57:39.000000000 -0800
2+++ enca-1.9/configure.ac 2006-02-15 00:57:46.000000000 -0800
3@@ -92,9 +92,6 @@
4 dnl And for gtk-doc
5 gtk_CHECK_GTK_DOC
6
7-dnl Check for good random number sources
8-AC_CHECK_FILES(/dev/random /dev/urandom /dev/srandom /dev/arandom)
9-
10 dnl Dirty path hack. Helps some people with badly set up search paths.
11 if test "$prefix" = "NONE"; then
12 LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
diff --git a/meta-oe/recipes-support/enca/enca/configure-remove-dumbness.patch b/meta-oe/recipes-support/enca/enca/configure-remove-dumbness.patch
new file mode 100644
index 000000000..6f6f3e320
--- /dev/null
+++ b/meta-oe/recipes-support/enca/enca/configure-remove-dumbness.patch
@@ -0,0 +1,26 @@
1--- enca-1.9/configure.ac.orig 2006-06-29 15:30:44.000000000 +0100
2+++ enca-1.9/configure.ac 2006-06-29 15:31:41.000000000 +0100
3@@ -92,14 +92,15 @@
4 dnl And for gtk-doc
5 gtk_CHECK_GTK_DOC
6
7-dnl Dirty path hack. Helps some people with badly set up search paths.
8-if test "$prefix" = "NONE"; then
9- LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
10- CPPFLAGS="$CPPFLAGS -I$ac_default_prefix/include"
11-else
12- LDFLAGS="$LDFLAGS -L$prefix/lib"
13- CPPFLAGS="$CPPFLAGS -I$prefix/include"
14-fi
15+# This is really dumb code
16+#dnl Dirty path hack. Helps some people with badly set up search paths.
17+#if test "$prefix" = "NONE"; then
18+# LDFLAGS="$LDFLAGS -L$ac_default_prefix/lib"
19+# CPPFLAGS="$CPPFLAGS -I$ac_default_prefix/include"
20+#else
21+# LDFLAGS="$LDFLAGS -L$prefix/lib"
22+# CPPFLAGS="$CPPFLAGS -I$prefix/include"
23+#fi
24
25 dnl Checks for libraries.
26 ye_CHECK_LIBM
diff --git a/meta-oe/recipes-support/enca/enca/dont-run-tests.patch b/meta-oe/recipes-support/enca/enca/dont-run-tests.patch
new file mode 100644
index 000000000..321d1e620
--- /dev/null
+++ b/meta-oe/recipes-support/enca/enca/dont-run-tests.patch
@@ -0,0 +1,13 @@
1Index: enca-1.9/Makefile.am
2===================================================================
3--- enca-1.9.orig/Makefile.am 2005-11-24 11:21:32.000000000 +0100
4+++ enca-1.9/Makefile.am 2006-04-11 11:14:21.832502904 +0200
5@@ -2,7 +2,7 @@
6 if MAINTAINER_MODE
7 SUBDIRS = tools data script lib src devel-docs test
8 else
9-SUBDIRS = tools script lib src devel-docs test
10+SUBDIRS = tools script lib src devel-docs
11 endif
12 man_MANS = man/enca.1
13
diff --git a/meta-oe/recipes-support/enca/enca/makefile-remove-tools.patch b/meta-oe/recipes-support/enca/enca/makefile-remove-tools.patch
new file mode 100644
index 000000000..accfbccd6
--- /dev/null
+++ b/meta-oe/recipes-support/enca/enca/makefile-remove-tools.patch
@@ -0,0 +1,13 @@
1--- enca-1.9/Makefile.am.orig 2006-06-29 15:34:55.000000000 +0100
2+++ enca-1.9/Makefile.am 2006-06-29 15:35:20.000000000 +0100
3@@ -1,8 +1,8 @@
4 # @(#) $Id: Makefile.am,v 1.35 2005/11/24 10:21:32 yeti Exp $
5 if MAINTAINER_MODE
6-SUBDIRS = tools data script lib src devel-docs test
7+SUBDIRS = data script lib src devel-docs test
8 else
9-SUBDIRS = tools script lib src devel-docs
10+SUBDIRS = script lib src devel-docs
11 endif
12 man_MANS = man/enca.1
13
diff --git a/meta-oe/recipes-support/enca/enca_1.9.bb b/meta-oe/recipes-support/enca/enca_1.9.bb
new file mode 100644
index 000000000..5472af4e5
--- /dev/null
+++ b/meta-oe/recipes-support/enca/enca_1.9.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Enca is an Extremely Naive Charset Analyser"
2SECTION = "libs"
3HOMEPAGE = "http://trific.ath.cx/software/enca/"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=24b9569831c46d4818450b55282476b4"
7
8SRC_URI = "http://www.sourcefiles.org/Networking/Tools/Miscellanenous/enca-${PV}.tar.bz2 \
9 file://configure-hack.patch \
10 file://dont-run-tests.patch \
11 file://configure-remove-dumbness.patch \
12 file://makefile-remove-tools.patch "
13
14SRC_URI[md5sum] = "b3581e28d68d452286fb0bfe58bed3b3"
15SRC_URI[sha256sum] = "02acfef2b24a9c842612da49338138311f909f1cd33933520c07b8b26c410f4d"
16
17inherit autotools
18
19EXTRA_OECONF = "--with-libiconv-prefix=${STAGING_DIR_HOST}${layout_exec_prefix}"
20
21do_configure_prepend() {
22 # remove failing test which checks for something that isn't even used
23 sed -i -e '/ye_FUNC_SCANF_MODIF_SIZE_T/d' configure.ac
24}
25
26do_configure_append() {
27 sed -i s:-I/usr/include::g Makefile
28 sed -i s:-I/usr/include::g */Makefile
29}
30
31do_compile() {
32 cd ${S}/tools && ${BUILD_CC} -o make_hash make_hash.c
33 cd ..
34 oe_runmake
35}
36