summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/syzkaller/syzkaller_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-test/syzkaller/syzkaller_git.bb')
-rw-r--r--meta-oe/recipes-test/syzkaller/syzkaller_git.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-oe/recipes-test/syzkaller/syzkaller_git.bb b/meta-oe/recipes-test/syzkaller/syzkaller_git.bb
index 2adc06a2b..b43207f2a 100644
--- a/meta-oe/recipes-test/syzkaller/syzkaller_git.bb
+++ b/meta-oe/recipes-test/syzkaller/syzkaller_git.bb
@@ -10,7 +10,13 @@ SRC_URI = "git://${GO_IMPORT};protocol=https;destsuffix=${BPN}-${PV}/src/${GO_IM
10 file://0001-sys-targets-targets.go-allow-users-to-override-hardc.patch;patchdir=src/${GO_IMPORT} \ 10 file://0001-sys-targets-targets.go-allow-users-to-override-hardc.patch;patchdir=src/${GO_IMPORT} \
11 file://0001-executor-Include-missing-linux-falloc.h.patch;patchdir=src/${GO_IMPORT} \ 11 file://0001-executor-Include-missing-linux-falloc.h.patch;patchdir=src/${GO_IMPORT} \
12 " 12 "
13SRCREV = "6d01f20890edf11b99bb54573025b11c1acd2d52" 13SRCREV = "25905f5d0a2a7883bd33491997556193582c6059"
14
15export GOPROXY = "https://proxy.golang.org,direct"
16# Workaround for network access issue during compile step.
17# This needs to be fixed in the recipes buildsystem so that
18# it can be accomplished during do_fetch task.
19do_compile[network] = "1"
14 20
15COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux" 21COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux"
16 22
@@ -26,6 +32,8 @@ export TARGETVMARCH = '${GOARCH}'
26 32
27CGO_ENABLED = "1" 33CGO_ENABLED = "1"
28 34
35LDFLAGS:append:class-target = "${@bb.utils.contains_any("TC_CXX_RUNTIME", "llvm android", " -lc++", " -lstdc++", d)}"
36
29DEPENDS:class-native += "qemu-system-native" 37DEPENDS:class-native += "qemu-system-native"
30 38
31do_compile:class-native() { 39do_compile:class-native() {
@@ -46,7 +54,7 @@ do_compile:class-target() {
46 unset GOOS 54 unset GOOS
47 unset GOARCH 55 unset GOARCH
48 56
49 oe_runmake GO="${GO}" CC="${CXX}" CFLAGS="${CXXFLAGS} ${LDFLAGS}" REV=${SRCREV} target 57 oe_runmake GO="${GO}" CFLAGS="${CXXFLAGS} ${LDFLAGS}" REV=${SRCREV} target
50} 58}
51 59
52do_install:class-native() { 60do_install:class-native() {