summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/fwts/fwts/0001-Makefile.am-Add-missing-link-with-zlib.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-test/fwts/fwts/0001-Makefile.am-Add-missing-link-with-zlib.patch')
-rw-r--r--meta-oe/recipes-test/fwts/fwts/0001-Makefile.am-Add-missing-link-with-zlib.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/fwts/fwts/0001-Makefile.am-Add-missing-link-with-zlib.patch b/meta-oe/recipes-test/fwts/fwts/0001-Makefile.am-Add-missing-link-with-zlib.patch
new file mode 100644
index 000000000..358f7c424
--- /dev/null
+++ b/meta-oe/recipes-test/fwts/fwts/0001-Makefile.am-Add-missing-link-with-zlib.patch
@@ -0,0 +1,43 @@
1From dd97e711b13af6f770db27abec316d5c9271c777 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 12 Jun 2023 10:25:55 -0700
4Subject: [PATCH] Makefile.am: Add missing link with zlib
5
6It uses functions e.g. gzopen/gzclone/gzgets which are provided by zlib
7therefore add it to linker flags.
8
9Fixes
10| aarch64-yoe-linux-ld.lld: error: undefined reference due to --no-allow-shlib-undefined: gzgets
11| >>> referenced by ../src/lib/src/.libs/libfwts.so
12|
13| aarch64-yoe-linux-ld.lld: error: undefined reference due to --no-allow-shlib-undefined: gzopen
14| >>> referenced by ../src/lib/src/.libs/libfwts.so
15|
16| aarch64-yoe-linux-ld.lld: error: undefined reference due to --no-allow-shlib-undefined: gzclose
17| >>> referenced by ../src/lib/src/.libs/libfwts.so
18| clang-16: error: linker command failed with exit code 1 (use -v to see invocation)
19| make[3]: *** [Makefile:2301: fwts] Error 1
20
21Upstream-Status: Pending
22
23Signed-off-by: Khem Raj <raj.khem@gmail.com>
24---
25 src/lib/src/Makefile.am | 2 +-
26 1 file changed, 1 insertion(+), 1 deletion(-)
27
28diff --git a/src/lib/src/Makefile.am b/src/lib/src/Makefile.am
29index 76c48d4..45eea88 100644
30--- a/src/lib/src/Makefile.am
31+++ b/src/lib/src/Makefile.am
32@@ -30,7 +30,7 @@ pkglib_LTLIBRARIES = libfwts.la
33 libfwts_la_LDFLAGS = -version-info 1:0:0
34
35 libfwts_la_LIBADD = \
36- -lm -lpthread -lbsd \
37+ -lm -lpthread -lbsd -lz \
38 @GIO_LIBS@ \
39 @GLIB_LIBS@
40
41--
422.41.0
43