summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch')
-rw-r--r--meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch b/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
new file mode 100644
index 000000000..cc8d11044
--- /dev/null
+++ b/meta-oe/recipes-support/syslog-ng/files/configure.ac-add-option-enable-thread-tls-to-manage-.patch
@@ -0,0 +1,50 @@
1configure.ac: add option --enable-thread-tls to manage thread ssl support
2
3Add option --enable-thread-tls to manage the including of thread
4local storage, so we could explicitly disable it.
5
6Upstream-Status: Pending
7
8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
9---
10 configure.ac | 17 +++++++++++------
11 1 file changed, 11 insertions(+), 6 deletions(-)
12
13diff --git a/configure.ac b/configure.ac
14index 474e094..cedca54 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -120,6 +120,9 @@ AC_ARG_ENABLE(memtrace,
18 AC_ARG_ENABLE(ssl,
19 [ --enable-ssl Enable SSL support.],,enable_ssl="auto")
20
21+AC_ARG_ENABLE(thread-tls,
22+ [ --enable-thread-tls Enable Thread Transport Layer Security support.],,enable_thread_tls="no")
23+
24 AC_ARG_ENABLE(dynamic-linking,
25 [ --enable-dynamic-linking Link everything dynamically.],,enable_dynamic_linking="auto")
26
27@@ -381,12 +384,14 @@ dnl ***************************************************************************
28 dnl Is the __thread keyword available?
29 dnl ***************************************************************************
30
31-AC_LINK_IFELSE([AC_LANG_PROGRAM(
32-[[#include <pthread.h>
33-__thread int a;
34-]],
35-[a=0;])],
36-[ac_cv_have_tls=yes; AC_DEFINE_UNQUOTED(HAVE_THREAD_KEYWORD, 1, "Whether Transport Layer Security is supported by the system")])
37+if test "x$enable_thread_tls" != "xno"; then
38+ AC_LINK_IFELSE([AC_LANG_PROGRAM(
39+ [[#include <pthread.h>
40+ __thread int a;
41+ ]],
42+ [a=0;])],
43+ [ac_cv_have_tls=yes; AC_DEFINE_UNQUOTED(HAVE_THREAD_KEYWORD, 1, "Whether Transport Layer Security is supported by the system")])
44+fi
45
46 dnl ***************************************************************************
47 dnl How to do static linking?
48--
491.9.1
50