summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch')
-rw-r--r--meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch b/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch
new file mode 100644
index 000000000..892399de7
--- /dev/null
+++ b/meta-oe/recipes-support/portaudio/portaudio-v19/0001-cmake-Use-GNUInstallDirs.patch
@@ -0,0 +1,49 @@
1From ced7af0420c1df0ac02f0c25e7c3534431ebd7fd Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 4 Jul 2021 17:09:49 -0700
4Subject: [PATCH] cmake: Use GNUInstallDirs
5
6Helps install cmakefiles in right libdir
7
8Upstream-Status: Submitted [https://github.com/PortAudio/portaudio/pull/610]
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 CMakeLists.txt | 12 +++++++-----
12 1 file changed, 7 insertions(+), 5 deletions(-)
13
14--- a/CMakeLists.txt
15+++ b/CMakeLists.txt
16@@ -6,6 +6,8 @@
17
18 CMAKE_MINIMUM_REQUIRED(VERSION 2.8)
19
20+include(GNUInstallDirs)
21+
22 # Check if the user is building PortAudio stand-alone or as part of a larger
23 # project. If this is part of a larger project (i.e. the CMakeLists.txt has
24 # been imported by some other CMakeLists.txt), we don't want to trump over
25@@ -452,18 +454,18 @@ IF(NOT PA_OUTPUT_OSX_FRAMEWORK AND NOT P
26 CONFIGURE_FILE(cmake_support/portaudio-2.0.pc.in ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc @ONLY)
27 INSTALL(FILES README.md DESTINATION share/doc/portaudio)
28 INSTALL(FILES LICENSE.txt DESTINATION share/doc/portaudio)
29- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc DESTINATION lib/pkgconfig)
30+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/portaudio-2.0.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
31 INSTALL(FILES ${PA_PUBLIC_INCLUDES} DESTINATION include)
32 INSTALL(TARGETS ${PA_TARGETS}
33 EXPORT portaudio-targets
34- RUNTIME DESTINATION bin
35- LIBRARY DESTINATION lib
36- ARCHIVE DESTINATION lib)
37- INSTALL(EXPORT portaudio-targets FILE "portaudioTargets.cmake" DESTINATION "lib/cmake/portaudio")
38+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
39+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
40+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
41+ INSTALL(EXPORT portaudio-targets FILE "portaudioTargets.cmake" DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/portaudio")
42 EXPORT(TARGETS ${PA_TARGETS} FILE "${PROJECT_BINARY_DIR}/cmake/portaudio/portaudioTargets.cmake")
43 INSTALL(FILES "${CMAKE_BINARY_DIR}/cmake/portaudio/portaudioConfig.cmake"
44 "${CMAKE_BINARY_DIR}/cmake/portaudio/portaudioConfigVersion.cmake"
45- DESTINATION "lib/cmake/portaudio")
46+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/cmake/portaudio")
47
48 IF (NOT TARGET uninstall)
49 CONFIGURE_FILE(