diff options
Diffstat (limited to 'meta-oe/recipes-support/poppler/poppler_20.12.1.bb')
-rw-r--r-- | meta-oe/recipes-support/poppler/poppler_20.12.1.bb | 51 |
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler_20.12.1.bb b/meta-oe/recipes-support/poppler/poppler_20.12.1.bb new file mode 100644 index 000000000..87a57523f --- /dev/null +++ b/meta-oe/recipes-support/poppler/poppler_20.12.1.bb | |||
@@ -0,0 +1,51 @@ | |||
1 | SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base" | ||
2 | HOMEPAGE = "https://poppler.freedesktop.org/" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
5 | |||
6 | SRC_URI = "http://poppler.freedesktop.org/${BP}.tar.xz \ | ||
7 | file://0001-Do-not-overwrite-all-our-build-flags.patch \ | ||
8 | file://basename-include.patch \ | ||
9 | " | ||
10 | SRC_URI[sha256sum] = "d0aa2586c0a4296c775f0d2045f28bb95a694113fc995f95350faa12930f7b35" | ||
11 | |||
12 | DEPENDS = "fontconfig zlib cairo lcms glib-2.0" | ||
13 | |||
14 | inherit cmake pkgconfig gobject-introspection | ||
15 | |||
16 | PACKAGECONFIG ??= "jpeg openjpeg png tiff nss splash" | ||
17 | PACKAGECONFIG[jpeg] = "-DWITH_JPEG=ON -DENABLE_DCTDECODER=libjpeg,-DWITH_JPEG=OFF -DENABLE_DCTDECODER=none,jpeg" | ||
18 | PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng" | ||
19 | PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff" | ||
20 | PACKAGECONFIG[curl] = "-DENABLE_LIBCURL=ON,-DENABLE_LIBCURL=OFF,curl" | ||
21 | PACKAGECONFIG[openjpeg] = "-DENABLE_LIBOPENJPEG=openjpeg2,-DENABLE_LIBOPENJPEG=none,openjpeg" | ||
22 | PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON,-DENABLE_QT5=OFF,qtbase qttools-native" | ||
23 | PACKAGECONFIG[nss] = "-DWITH_NSS3=ON,-DWITH_NSS3=OFF,nss" | ||
24 | PACKAGECONFIG[splash] = "-DENABLE_SPLASH=ON,-DENABLE_SPLASH=OFF,boost" | ||
25 | |||
26 | # surprise - did not expect this to work :) | ||
27 | inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)} | ||
28 | |||
29 | SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}" | ||
30 | |||
31 | EXTRA_OECMAKE += " \ | ||
32 | -DENABLE_CMS=lcms2 \ | ||
33 | -DENABLE_UNSTABLE_API_ABI_HEADERS=ON \ | ||
34 | -DBUILD_GTK_TESTS=OFF \ | ||
35 | -DENABLE_ZLIB=ON \ | ||
36 | -DCMAKE_CXX_IMPLICIT_INCLUDE_DIRECTORIES:PATH='${STAGING_INCDIR}' \ | ||
37 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_GOBJECT_INTROSPECTION=ON', '-DENABLE_GOBJECT_INTROSPECTION=OFF', d)} \ | ||
38 | " | ||
39 | |||
40 | do_configure_append() { | ||
41 | # poppler macro uses pkg-config to check for g-ir runtimes. Something | ||
42 | # makes them point to /usr/bin. Align them to sysroot - that's where the | ||
43 | # gir-wrappers are: | ||
44 | sed -i 's: ${bindir}/g-ir: ${STAGING_BINDIR}/g-ir:' ${B}/build.ninja | ||
45 | } | ||
46 | |||
47 | PACKAGES =+ "libpoppler libpoppler-glib" | ||
48 | FILES_libpoppler = "${libdir}/libpoppler.so.*" | ||
49 | FILES_libpoppler-glib = "${libdir}/libpoppler-glib.so.*" | ||
50 | |||
51 | RDEPENDS_libpoppler = "poppler-data" | ||