summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch')
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch b/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch
new file mode 100644
index 000000000..7ed795ef7
--- /dev/null
+++ b/meta-oe/recipes-support/poppler/poppler/0001-glib-CMakeLists.txt-Add-libpoppler-to-link-along-wit.patch
@@ -0,0 +1,29 @@
1From d488de23b75b2f3e235f1c184b2253d1402b4c0f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 10 May 2018 23:47:56 -0700
4Subject: [PATCH] glib/CMakeLists.txt: Add libpoppler to link along with
5 poppler-glib
6
7This is required since poppler-glib uses symbols from poppler and
8we use --as-needed
9
10Upstream-Status: Pending
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 glib/CMakeLists.txt | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
18index 33c6608..87e1b44 100644
19--- a/glib/CMakeLists.txt
20+++ b/glib/CMakeLists.txt
21@@ -127,7 +127,7 @@ if (HAVE_INTROSPECTION AND BUILD_SHARED_LIBS)
22 get_directory_property(_tmp_includes INCLUDE_DIRECTORIES)
23 _list_prefix(_includes _tmp_includes "-I")
24 set(Poppler_0_18_gir_CFLAGS ${_includes} -L${CMAKE_BINARY_DIR})
25- set(Poppler_0_18_gir_LIBS poppler-glib)
26+ set(Poppler_0_18_gir_LIBS poppler-glib poppler)
27 _list_prefix(_abs_introspection_files introspection_files "${CMAKE_CURRENT_SOURCE_DIR}/")
28 list(APPEND _abs_introspection_files
29 ${CMAKE_CURRENT_BINARY_DIR}/poppler-enums.c