summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb')
-rw-r--r--meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb b/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb
new file mode 100644
index 000000000..88033e58c
--- /dev/null
+++ b/meta-oe/recipes-support/opentelemetry/opentelemetry-cpp_1.15.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Open Telemetry Library"
2DESCRIPTION = "An Observability framework to create and manage telemetry data \
3such as traces, metrics, and logs."
4HOMEPAGE = "https://github.com/open-telemetry/opentelemetry-cpp"
5SECTION = "libs"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9DEPENDS = "nlohmann-json"
10
11SRC_URI = "git://github.com/open-telemetry/opentelemetry-cpp.git;protocol=https;branch=main;"
12SRCREV = "054b0dc207c1f58e290d78cdaac5f314bc328b31"
13
14S = "${WORKDIR}/git"
15inherit cmake pkgconfig lib_package
16
17PACKAGECONFIG ?= "opentelemety_install otlp_api"
18
19PACKAGECONFIG[opentelemety_install]="-DOPENTELEMETRY_INSTALL=ON,-DOPENTELEMETRY_INSTALL=OFF"
20PACKAGECONFIG[build_package]="-DBUILD_PACKAGE=ON,-DBUILD_PACKAGE=OFF"
21PACKAGECONFIG[otlp_api]="-DWITH_OTLP_API=ON,-DWITH_OTLP_API=OFF"
22PACKAGECONFIG[otlp_grpc]="-DWITH_OTLP_GRPC=ON,-DWITH_OTLP_GRPC=OFF"
23PACKAGECONFIG[otlp_http]="-DWITH_OTLP_HTTP=ON,-DWITH_OTLP_HTTP=OFF"
24PACKAGECONFIG[otlp_prometheus]="-DWITH_PROMETHEUS=ON,-DWITH_PROMETHEUS=OFF"
25PACKAGECONFIG[benchmark]="-DWITH_BENCHMARK=ON,-DWITH_BENCHMARK=OFF"
26PACKAGECONFIG[testing]="-DBUILD_TESTING=ON,-DBUILD_TESTING=OFF"