summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mysql/files/autofoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/mysql/files/autofoo.patch')
-rw-r--r--meta-oe/recipes-support/mysql/files/autofoo.patch319
1 files changed, 0 insertions, 319 deletions
diff --git a/meta-oe/recipes-support/mysql/files/autofoo.patch b/meta-oe/recipes-support/mysql/files/autofoo.patch
deleted file mode 100644
index 669393a23..000000000
--- a/meta-oe/recipes-support/mysql/files/autofoo.patch
+++ /dev/null
@@ -1,319 +0,0 @@
1diff -aurp mysql-4.1.22.old/acinclude.m4 mysql-4.1.22/acinclude.m4
2--- mysql-4.1.22.old/acinclude.m4 2008-09-18 13:00:13.000000000 -0500
3+++ mysql-4.1.22/acinclude.m4 2008-09-18 12:58:41.000000000 -0500
4@@ -1,5 +1,88 @@
5 # Local macros for automake & autoconf
6
7+AH_TEMPLATE([SPRINTF_RETURNS_INT], [sprintf returns an int])
8+AH_TEMPLATE([SPRINTF_RETURNS_PTR], [sprintf returns a char *])
9+AH_TEMPLATE([SPRINTF_RETURNS_GARBAGE], [sprintf returns something unknown to us])
10+
11+AC_DEFUN([MYSQL_SPRINTF_RET], [
12+ AC_CACHE_CHECK([return type of sprintf],
13+ [mysql_cv_func_sprintf_ret], [
14+ old_CFLAGS="$CFLAGS"
15+ CFLAGS="$CFLAGS -Werror"
16+ AC_COMPILE_IFELSE([
17+#include <stdio.h>
18+int sprintf(char *str, const char *format, ...);
19+ ], [mysql_cv_func_sprintf_ret=int],
20+ AC_COMPILE_IFELSE([
21+#include <stdio.h>
22+char * sprintf(char *str, const char *format, ...);
23+ ], [mysql_cv_func_sprintf_ret=ptr],
24+ [mysql_cv_func_sprintf_ret=unknown])
25+ )
26+ CFLAGS="$old_CFLAGS"
27+ ])
28+ if test x"$mysql_cv_func_sprintf_ret" = "xint"; then
29+ AC_DEFINE([SPRINTF_RETURNS_INT], [1])
30+ elif test x"$mysql_cv_func_sprintf_ret" = "xptr"; then
31+ AC_DEFINE([SPRINTF_RETURNS_PTR], [1])
32+ else
33+ AC_DEFINE([SPRINTF_RETURNS_GARBAGE], [1])
34+ fi
35+])
36+
37+# _MYSQL_FUNC_ATOMIC_ADD
38+# ----------------------
39+# Check for Linux specific atomic_add function
40+AC_DEFUN([_MYSQL_FUNC_ATOMIC_ADD],
41+[AC_CACHE_CHECK([for atomic_add], [mysql_cv_func_atomic_add],
42+[AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <asm/atomic.h>]],
43+ [
44+int main()
45+{
46+ atomic_t v;
47+
48+ atomic_set(&v, 23);
49+ atomic_add(5, &v);
50+ return atomic_read(&v) == 28 ? 0 : -1;
51+}
52+ ])],
53+ [mysql_cv_func_atomic_add=yes],
54+ [mysql_cv_func_atomic_add=no])])
55+ if test x"$mysql_func_atomic_add" = "xyes"; then
56+ AC_DEFINE([HAVE_ATOMIC_ADD], [1])
57+ fi[]dnl
58+])# _MYSQL_FUNC_ATOMIC_ADD
59+
60+# _MYSQL_FUNC_ATOMIC_SUB
61+# ----------------------
62+# Check for Linux specific atomic_sub function
63+AC_DEFUN([_MYSQL_FUNC_ATOMIC_SUB],
64+[AC_CACHE_CHECK([for atomic_sub], [mysql_cv_func_atomic_sub],
65+[AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <asm/atomic.h>]],
66+ [
67+int main()
68+{
69+ atomic_t v;
70+
71+ atomic_set(&v, 23);
72+ atomic_sub(5, &v);
73+ return atomic_read(&v) == 18 ? 0 : -1;
74+}
75+ ])],
76+ [mysql_cv_func_atomic_sub=yes],
77+ [mysql_cv_func_atomic_sub=no])])
78+ if test x"$mysql_func_atomic_sub" = "xyes"; then
79+ AC_DEFINE([HAVE_ATOMIC_SUB], [1])
80+ fi[]dnl
81+])# _MYSQL_FUNC_ATOMIC_SUB
82+
83+# MYSQL_FUNCS_ATOMIC
84+# ------------------
85+# Check for Linux specific atomic add and sub functions
86+AC_DEFUN([MYSQL_FUNCS_ATOMIC], [
87+ AC_REQUIRE([_MYSQL_FUNC_ATOMIC_ADD])dnl
88+ AC_REQUIRE([_MYSQL_FUNC_ATOMIC_SUB])dnl
89+])# MYSQL_FUNCS_ATOMIC
90
91 AC_DEFUN([MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY], [
92 AC_CACHE_CHECK([HIST_ENTRY is declared in readline/readline.h], mysql_cv_hist_entry_declared,
93@@ -344,7 +427,7 @@ dnl ------------------------------------
94 AC_DEFUN([MYSQL_CHECK_ULONG],
95 [AC_MSG_CHECKING(for type ulong)
96 AC_CACHE_VAL(ac_cv_ulong,
97-[AC_TRY_RUN([#include <stdio.h>
98+[AC_TRY_LINK([#include <stdio.h>
99 #include <sys/types.h>
100 main()
101 {
102@@ -362,7 +445,7 @@ fi
103 AC_DEFUN([MYSQL_CHECK_UCHAR],
104 [AC_MSG_CHECKING(for type uchar)
105 AC_CACHE_VAL(ac_cv_uchar,
106-[AC_TRY_RUN([#include <stdio.h>
107+[AC_TRY_LINK([#include <stdio.h>
108 #include <sys/types.h>
109 main()
110 {
111@@ -380,7 +463,7 @@ fi
112 AC_DEFUN([MYSQL_CHECK_UINT],
113 [AC_MSG_CHECKING(for type uint)
114 AC_CACHE_VAL(ac_cv_uint,
115-[AC_TRY_RUN([#include <stdio.h>
116+[AC_TRY_LINK([#include <stdio.h>
117 #include <sys/types.h>
118 main()
119 {
120@@ -399,7 +482,7 @@ fi
121 AC_DEFUN([MYSQL_CHECK_IN_ADDR_T],
122 [AC_MSG_CHECKING(for type in_addr_t)
123 AC_CACHE_VAL(ac_cv_in_addr_t,
124-[AC_TRY_RUN([#include <stdio.h>
125+[AC_TRY_LINK([#include <stdio.h>
126 #include <sys/types.h>
127 #include <sys/socket.h>
128 #include <netinet/in.h>
129@@ -460,7 +543,7 @@ fi
130 AC_DEFUN([MYSQL_CHECK_FP_EXCEPT],
131 [AC_MSG_CHECKING(for type fp_except)
132 AC_CACHE_VAL(ac_cv_fp_except,
133-[AC_TRY_RUN([#include <stdio.h>
134+[AC_TRY_LINK([#include <stdio.h>
135 #include <sys/types.h>
136 #include <ieeefp.h>
137 main()
138diff -aurp mysql-4.1.22.old/configure.in mysql-4.1.22/configure.in
139--- mysql-4.1.22.old/configure.in 2008-09-18 13:00:14.000000000 -0500
140+++ mysql-4.1.22/configure.in 2008-09-18 12:54:00.000000000 -0500
141@@ -236,8 +236,6 @@ then
142 else
143 AC_PATH_PROG(AS, as, as)
144 fi
145-# Still need ranlib for readline; local static use only so no libtool.
146-AC_PROG_RANLIB
147 # We use libtool
148 #AC_LIBTOOL_WIN32_DLL
149 AC_PROG_LIBTOOL
150@@ -258,44 +256,7 @@ AC_PROG_YACC
151 AC_CHECK_PROG(PDFMANUAL, pdftex, manual.pdf)
152 AC_CHECK_PROG(DVIS, tex, manual.dvi)
153
154-AC_MSG_CHECKING("return type of sprintf")
155-
156-#check the return type of sprintf
157-case $SYSTEM_TYPE in
158- *netware*)
159- AC_DEFINE(SPRINTF_RETURNS_INT, [1]) AC_MSG_RESULT("int")
160- ;;
161- *)
162-AC_TRY_RUN([
163- int main()
164- {
165- char* s = "hello";
166- char buf[6];
167- if((int)sprintf(buf, s) == strlen(s))
168- return 0;
169-
170- return -1;
171- }
172- ],
173- [AC_DEFINE(SPRINTF_RETURNS_INT, [1], [POSIX sprintf])
174- AC_MSG_RESULT("int")],
175- [AC_TRY_RUN([
176- int main()
177- {
178- char* s = "hello";
179- char buf[6];
180- if((char*)sprintf(buf,s) == buf + strlen(s))
181- return 0;
182- return -1;
183- } ],
184- [AC_DEFINE(SPRINTF_RETURNS_PTR, [1], [Broken sprintf])
185- AC_MSG_RESULT("ptr")],
186- [AC_DEFINE(SPRINTF_RETURNS_GARBAGE, [1], [Broken sprintf])
187- AC_MSG_RESULT("garbage")])
188- ])
189- ;;
190-esac
191-
192+MYSQL_SPRINTF_RET
193
194 # option, cache_name, variable,
195 # code to execute if yes, code to exectute if fail
196@@ -878,47 +839,7 @@ struct request_info *req;
197 AC_SUBST(WRAPLIBS)
198
199 if test "$TARGET_LINUX" = "true"; then
200- AC_MSG_CHECKING([for atomic operations])
201-
202- AC_LANG_SAVE
203- AC_LANG_CPLUSPLUS
204-
205- atom_ops=
206- AC_TRY_RUN([
207-#include <asm/atomic.h>
208-int main()
209-{
210- atomic_t v;
211-
212- atomic_set(&v, 23);
213- atomic_add(5, &v);
214- return atomic_read(&v) == 28 ? 0 : -1;
215-}
216- ],
217- [AC_DEFINE([HAVE_ATOMIC_ADD], [1],
218- [atomic_add() from <asm/atomic.h> (Linux only)])
219- atom_ops="${atom_ops}atomic_add "],
220- )
221- AC_TRY_RUN([
222-#include <asm/atomic.h>
223-int main()
224-{
225- atomic_t v;
226-
227- atomic_set(&v, 23);
228- atomic_sub(5, &v);
229- return atomic_read(&v) == 18 ? 0 : -1;
230-}
231- ],
232- [AC_DEFINE([HAVE_ATOMIC_SUB], [1],
233- [atomic_sub() from <asm/atomic.h> (Linux only)])
234- atom_ops="${atom_ops}atomic_sub "],
235- )
236-
237- if test -z "$atom_ops"; then atom_ops="no"; fi
238- AC_MSG_RESULT($atom_ops)
239-
240- AC_LANG_RESTORE
241+ MYSQL_FUNC_ATOMIC
242
243 AC_ARG_WITH(pstack,
244 [ --with-pstack Use the pstack backtrace library],
245@@ -971,13 +892,13 @@ fi
246 # Later in this script LIBS will be augmented with a threads library.
247 NON_THREADED_LIBS="$LIBS"
248
249-AC_MSG_CHECKING([for int8])
250+AC_CACHE_CHECK([for int8], [mysql_cv_type_int8], [
251 case $SYSTEM_TYPE in
252 *netware)
253 AC_MSG_RESULT([no])
254 ;;
255 *)
256-AC_TRY_RUN([
257+AC_LINK_IFELSE([AC_LANG_PROGRAM([[
258 #ifdef HAVE_STDLIB_H
259 #include <stdlib.h>
260 #endif
261@@ -988,22 +909,21 @@ AC_TRY_RUN([
262
263 #ifdef HAVE_SYS_TYPES_H
264 #include <sys/types.h>
265-#endif
266-
267+#endif]], [
268 int main()
269 {
270 int8 i;
271 return 0;
272-}
273-],
274-[AC_DEFINE([HAVE_INT_8_16_32], [1],
275- [whether int8, int16 and int32 types exist])
276-AC_MSG_RESULT([yes])],
277-[AC_MSG_RESULT([no])]
278-)
279+}])], [mysql_cv_type_int8=yes], [mysql_cv_type_int8=no])
280 ;;
281 esac
282
283+if test x"$mysql_cv_type_int8" = "xyes"; then
284+ AC_DEFINE([HAVE_INT_8_16_32], [1],
285+ [whether int8, int16 and int32 types exist])
286+fi
287+])
288+
289 #
290 # Some system specific hacks
291 #
292@@ -1814,7 +1734,7 @@ then
293 AC_MSG_ERROR("MySQL needs a long long type.")
294 fi
295 # off_t is not a builtin type
296-MYSQL_CHECK_SIZEOF(off_t, 4)
297+AC_CHECK_SIZEOF(off_t, 4)
298 if test "$ac_cv_sizeof_off_t" -eq 0
299 then
300 AC_MSG_ERROR("MySQL needs a off_t type.")
301diff -aurp mysql-4.1.22.old/innobase/configure.in mysql-4.1.22/innobase/configure.in
302--- mysql-4.1.22.old/innobase/configure.in 2008-09-18 13:00:14.000000000 -0500
303+++ mysql-4.1.22/innobase/configure.in 2008-09-18 12:55:39.000000000 -0500
304@@ -3,6 +3,7 @@ AC_INIT
305 AC_CANONICAL_SYSTEM
306 AM_MAINTAINER_MODE
307 AM_CONFIG_HEADER(ib_config.h)
308+AC_CONFIG_AUX_DIR([..])
309 AM_INIT_AUTOMAKE(ib, 0.90)
310
311 # This is need before AC_PROG_CC
312@@ -32,7 +33,6 @@ CFLAGS="$CFLAGS "
313 CXXFLAGS="$CXXFLAGS "
314
315 AC_PROG_CC
316-AC_PROG_RANLIB
317 AC_PROG_INSTALL
318 AC_PROG_LIBTOOL
319 AC_CHECK_HEADERS(aio.h sched.h)