summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mongodb/mongodb_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/mongodb/mongodb_git.bb')
-rw-r--r--meta-oe/recipes-support/mongodb/mongodb_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mongodb/mongodb_git.bb b/meta-oe/recipes-support/mongodb/mongodb_git.bb
new file mode 100644
index 000000000..2701c4cfc
--- /dev/null
+++ b/meta-oe/recipes-support/mongodb/mongodb_git.bb
@@ -0,0 +1,39 @@
1SUMMARY = "mongodb"
2LICENSE = "AGPL-3.0 & Apache-2.0"
3LIC_FILES_CHKSUM = "file://GNU-AGPL-3.0.txt;md5=73f1eb20517c55bf9493b7dd6e480788 \
4 file://APACHE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS = "openssl libpcre boost libpcap"
7# Mongo uses tcmalloc on x86_64, which is provided by gperftools
8DEPENDS_append_x86-64 = " gperftools"
9
10inherit scons
11
12PV = "2.6.0+git${SRCPV}"
13SRCREV = "be1905c24c7e5ea258e537fbf0d2c502c4fc6de2"
14SRC_URI = "git://github.com/mongodb/mongo.git;branch=v2.6 \
15 file://0001-Make-it-possible-to-disable-the-use-of-v8.patch \
16 file://0002-Fix-linking-when-scripting-is-disabled.patch \
17 file://0003-Do-not-build-mongo-binary-when-scripting-is-disabled.patch \
18 file://0004-replace-os.uname-with-os.getenv-OE_TARGET_ARCH.patch \
19 file://0005-GCC-4.7-supports-atomic-ops-for-armv5-and-up-but-onl.patch \
20 "
21
22S = "${WORKDIR}/git"
23
24export OE_TARGET_ARCH="${TARGET_ARCH}"
25
26EXTRA_OESCONS = "--prefix=${D}${prefix} \
27 --propagate-shell-environment \
28 --cc-use-shell-environment \
29 --cxx-use-shell-environment \
30 --ld='${TARGET_PREFIX}g++' \
31 --ssl \
32 --use-system-pcre \
33 --use-system-boost \
34 --use-system-tcmalloc \
35 --disable-scripting \
36 --nostrip \
37 mongod mongos"
38
39