summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_0.8.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_0.8.9.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.8.9.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.8.9.bb b/meta-oe/recipes-support/libssh/libssh_0.8.9.bb
new file mode 100644
index 000000000..39ed8a8fb
--- /dev/null
+++ b/meta-oe/recipes-support/libssh/libssh_0.8.9.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
2HOMEPAGE = "http://www.libssh.org"
3SECTION = "libs"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=dabb4958b830e5df11d2b0ed8ea255a0"
6
7DEPENDS = "zlib openssl libgcrypt"
8
9SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.8"
10SRCREV = "04685a74df9ce1db1bc116a83a0da78b4f4fa1f8"
11
12S = "${WORKDIR}/git"
13
14inherit cmake
15
16PACKAGECONFIG ??=""
17PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
18
19ARM_INSTRUCTION_SET_armv5 = "arm"
20
21EXTRA_OECMAKE = " \
22 -DWITH_GCRYPT=1 \
23 -DWITH_PCAP=1 \
24 -DWITH_SFTP=1 \
25 -DWITH_ZLIB=1 \
26 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
27 "
28
29do_configure_prepend () {
30 # Disable building of examples
31 sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
32 || bbfatal "Failed to disable examples"
33}
34
35TOOLCHAIN = "gcc"