summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_0.8.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_0.8.4.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.8.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.8.4.bb b/meta-oe/recipes-support/libssh/libssh_0.8.4.bb
new file mode 100644
index 000000000..8566741a3
--- /dev/null
+++ b/meta-oe/recipes-support/libssh/libssh_0.8.4.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
2HOMEPAGE = "http://www.libssh.org"
3SECTION = "libs"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
6
7DEPENDS = "zlib openssl libgcrypt"
8
9SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.8"
10SRCREV = "789df0b7d0c7abd6b85db9fc5247e146e3d4ddba"
11
12S = "${WORKDIR}/git"
13
14inherit cmake
15
16PACKAGECONFIG ??=""
17PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
18
19EXTRA_OECMAKE = " \
20 -DWITH_GCRYPT=1 \
21 -DWITH_PCAP=1 \
22 -DWITH_SFTP=1 \
23 -DWITH_ZLIB=1 \
24 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
25 "
26
27do_configure_prepend () {
28 # Disable building of examples
29 sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
30 || bbfatal "Failed to disable examples"
31}
32
33TOOLCHAIN = "gcc"