summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_0.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_0.6.3.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.6.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.6.3.bb b/meta-oe/recipes-support/libssh/libssh_0.6.3.bb
new file mode 100644
index 000000000..771a47a6c
--- /dev/null
+++ b/meta-oe/recipes-support/libssh/libssh_0.6.3.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol"
2HOMEPAGE = "http://www.libssh.org"
3SECTION = "libs"
4
5DEPENDS = "zlib openssl libgcrypt"
6
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=388a4fb1dea8ceae0be78ba9b01fc139"
9
10SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=v0-6"
11SRCREV = "87145387aa12b720b52d6bc75b4dd6cd058c868a"
12S = "${WORKDIR}/git"
13
14EXTRA_OECMAKE = " \
15 -DWITH_GCRYPT=1 \
16 -DWITH_PCAP=1 \
17 -DWITH_SFTP=1 \
18 -DWITH_ZLIB=1 \
19 "
20
21inherit cmake
22
23do_configure_prepend () {
24 # Disable building of examples
25 sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \
26 || bbfatal "Failed to disable examples"
27}
28
29FILES_${PN}-dev += "${libdir}/cmake"