summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libssh/libssh_0.10.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libssh/libssh_0.10.4.bb')
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.10.4.bb21
1 files changed, 18 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.10.4.bb b/meta-oe/recipes-support/libssh/libssh_0.10.4.bb
index 3a57a728a..801644d95 100644
--- a/meta-oe/recipes-support/libssh/libssh_0.10.4.bb
+++ b/meta-oe/recipes-support/libssh/libssh_0.10.4.bb
@@ -6,16 +6,20 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=dabb4958b830e5df11d2b0ed8ea255a0"
6 6
7DEPENDS = "zlib openssl" 7DEPENDS = "zlib openssl"
8 8
9SRC_URI = "git://git.libssh.org/projects/libssh.git;protocol=https;branch=stable-0.10" 9SRC_URI = "git://git.libssh.org/projects/libssh.git;protocol=https;branch=stable-0.10 \
10 file://0001-tests-CMakeLists.txt-do-not-search-ssh-sshd-commands.patch \
11 file://run-ptest \
12 "
10SRCREV = "e8322817a9e5aaef0698d779ddd467a209a85d85" 13SRCREV = "e8322817a9e5aaef0698d779ddd467a209a85d85"
11 14
12S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
13 16
14inherit cmake 17inherit cmake ptest
15 18
16PACKAGECONFIG ??= "gcrypt" 19PACKAGECONFIG ??= "gcrypt ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
17PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, " 20PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
18PACKAGECONFIG[gcrypt] = "-DWITH_GCRYPT=1, -DWITH_GCRYPT=0, libgcrypt, " 21PACKAGECONFIG[gcrypt] = "-DWITH_GCRYPT=1, -DWITH_GCRYPT=0, libgcrypt, "
22PACKAGECONFIG[tests] = "-DUNIT_TESTING=1, -DUNIT_TESTING=0, cmocka"
19 23
20ARM_INSTRUCTION_SET:armv5 = "arm" 24ARM_INSTRUCTION_SET:armv5 = "arm"
21 25
@@ -26,4 +30,15 @@ EXTRA_OECMAKE = " \
26 -DWITH_EXAMPLES=0 \ 30 -DWITH_EXAMPLES=0 \
27 " 31 "
28 32
33do_compile:prepend () {
34 if [ ${PTEST_ENABLED} = "1" ]; then
35 sed -i -e 's|${B}|${PTEST_PATH}|g' ${B}/config.h
36 fi
37}
38
39do_install_ptest () {
40 install -d ${D}${PTEST_PATH}/tests
41 cp -f ${B}/tests/unittests/torture_* ${D}${PTEST_PATH}/tests/
42}
43
29BBCLASSEXTEND = "native nativesdk" 44BBCLASSEXTEND = "native nativesdk"