summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch')
-rw-r--r--meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch b/meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch
new file mode 100644
index 000000000..ee217441b
--- /dev/null
+++ b/meta-oe/recipes-support/libnl/libnl/fix-pktloc-dep-race.patch
@@ -0,0 +1,20 @@
1Index: libnl-2.0/lib/Makefile.am
2===================================================================
3--- libnl-2.0.orig/lib/Makefile.am
4+++ libnl-2.0/lib/Makefile.am
5@@ -27,11 +27,15 @@ CLEANFILES = \
6 route/pktloc_grammar.c route/pktloc_grammar.h \
7 route/pktloc_syntax.c route/pktloc_syntax.h
8
9+BUILT_SOURCES = route/pktloc_syntax.h route/pktloc_grammar.h
10+
11 # Hack to avoid using ylwrap. It does not function correctly in combination
12 # with --header-file=
13+route/pktloc_grammar.h: route/pktloc_grammar.c
14 route/pktloc_grammar.c: route/pktloc_grammar.l
15 $(LEX) --header-file=route/pktloc_grammar.h $(LFLAGS) -o $@ $^
16
17+route/pktloc_syntax.h: route/pktloc_syntax.c
18 route/pktloc_syntax.c: route/pktloc_syntax.y
19 $(YACC) -d $(YFLAGS) -o $@ $^
20