summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libjs
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libjs')
-rw-r--r--meta-oe/recipes-support/libjs/libjs-jquery-globalize_1.7.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libjs/libjs-jquery-globalize_1.7.0.bb b/meta-oe/recipes-support/libjs/libjs-jquery-globalize_1.7.0.bb
new file mode 100644
index 000000000..a87c5bf75
--- /dev/null
+++ b/meta-oe/recipes-support/libjs/libjs-jquery-globalize_1.7.0.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "A JavaScript library for internationalization and localization that leverages the official Unicode CLDR JSON data"
2SECTION = "console/network"
3HOMEPAGE = "https://github.com/globalizejs/globalize"
4LICENSE = "MIT"
5
6S = "${WORKDIR}/git"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=4db68fb4d1d9986d736b35039f2ad9ea"
9
10SRC_URI = "git://github.com/globalizejs/globalize;tag=1.7.0;nobranch=1"
11
12FILES:${PN} = "${datadir}/javascript/jquery-globalize"
13FILES:${PN}-doc += "${docdir}/${PN}"
14
15do_install() {
16 install -d ${D}${datadir}/javascript/jquery-globalize/
17 install -m 0644 ${S}/dist/*.js ${D}${datadir}/javascript/jquery-globalize/
18 install -m 0644 ${S}/dist/globalize/*.js ${D}${datadir}/javascript/jquery-globalize/
19
20 install -d ${D}${docdir}/${PN}/
21 install -m 0644 ${S}/LICENSE ${D}${docdir}/${PN}/
22}