summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libgcrypt
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libgcrypt')
-rw-r--r--meta-oe/recipes-support/libgcrypt/libgcrypt.inc32
-rw-r--r--meta-oe/recipes-support/libgcrypt/libgcrypt/add-pkgconfig-support.patch49
-rw-r--r--meta-oe/recipes-support/libgcrypt/libgcrypt_1.4.6.bb3
-rw-r--r--meta-oe/recipes-support/libgcrypt/libgcrypt_1.4.6.bbappend2
4 files changed, 2 insertions, 84 deletions
diff --git a/meta-oe/recipes-support/libgcrypt/libgcrypt.inc b/meta-oe/recipes-support/libgcrypt/libgcrypt.inc
deleted file mode 100644
index 8eb78a9d4..000000000
--- a/meta-oe/recipes-support/libgcrypt/libgcrypt.inc
+++ /dev/null
@@ -1,32 +0,0 @@
1DESCRIPTION = "A general purpose cryptographic library based on the code from GnuPG"
2HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4SECTION = "libs"
5
6BBCLASSEXTEND = "native"
7
8# helper program gcryptrnd and getrandom are under GPL, rest LGPL
9LICENSE = "GPLv2+ & LGPLv2.1+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
11 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff"
12
13DEPENDS = "libgpg-error"
14
15SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz \
16 file://add-pkgconfig-support.patch"
17
18inherit autotools binconfig pkgconfig
19
20EXTRA_OECONF = "--without-pth --disable-asm --with-capabilities"
21
22# libgcrypt.pc is added locally and thus installed here
23do_install_append() {
24 install -d ${D}/${libdir}/pkgconfig
25 install -m 0644 ${S}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
26}
27
28ARM_INSTRUCTION_SET = "arm"
29
30# move libgcrypt-config into -dev package
31FILES_${PN} = "${libdir}/lib*.so.*"
32FILES_${PN}-dev += "${bindir} ${libdir}/pkgconfig/*.pc"
diff --git a/meta-oe/recipes-support/libgcrypt/libgcrypt/add-pkgconfig-support.patch b/meta-oe/recipes-support/libgcrypt/libgcrypt/add-pkgconfig-support.patch
deleted file mode 100644
index 24a59787a..000000000
--- a/meta-oe/recipes-support/libgcrypt/libgcrypt/add-pkgconfig-support.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1Index: libgcrypt-1.2.4/configure.ac
2===================================================================
3--- libgcrypt-1.2.4.orig/configure.ac 2008-03-19 22:14:50.000000000 +0000
4+++ libgcrypt-1.2.4/configure.ac 2008-03-19 22:14:58.000000000 +0000
5@@ -807,6 +807,7 @@
6 doc/Makefile
7 src/Makefile
8 src/gcrypt.h
9+src/libgcrypt.pc
10 src/libgcrypt-config
11 tests/Makefile
12 w32-dll/Makefile
13Index: libgcrypt-1.2.4/src/libgcrypt.pc.in
14===================================================================
15--- /dev/null 1970-01-01 00:00:00.000000000 +0000
16+++ libgcrypt-1.2.4/src/libgcrypt.pc.in 2008-03-19 22:14:58.000000000 +0000
17@@ -0,0 +1,32 @@
18+# Process this file with autoconf to produce a pkg-config metadata file.
19+# Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation
20+# Author: Simon Josefsson
21+#
22+# This file is free software; as a special exception the author gives
23+# unlimited permission to copy and/or distribute it, with or without
24+# modifications, as long as this notice is preserved.
25+#
26+# This file is distributed in the hope that it will be useful, but
27+# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
28+# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
29+
30+prefix=@prefix@
31+exec_prefix=@exec_prefix@
32+libdir=@libdir@
33+includedir=@includedir@
34+
35+# API info
36+api_version=@LIBGCRYPT_CONFIG_API_VERSION@
37+
38+# Misc information.
39+symmetric_ciphers=@LIBGCRYPT_CIPHERS@
40+asymmetric_ciphers=@LIBGCRYPT_PUBKEY_CIPHERS@
41+digests=@LIBGCRYPT_DIGESTS@
42+
43+Name: libgcrypt
44+Description: GNU crypto library
45+URL: http://www.gnupg.org
46+Version: @VERSION@
47+Libs: -L${libdir} -lgcrypt
48+Libs.private: -L${libdir} -lgpg-error
49+Cflags: -I${includedir}
diff --git a/meta-oe/recipes-support/libgcrypt/libgcrypt_1.4.6.bb b/meta-oe/recipes-support/libgcrypt/libgcrypt_1.4.6.bb
deleted file mode 100644
index a59243791..000000000
--- a/meta-oe/recipes-support/libgcrypt/libgcrypt_1.4.6.bb
+++ /dev/null
@@ -1,3 +0,0 @@
1require libgcrypt.inc
2
3PR = "r0"
diff --git a/meta-oe/recipes-support/libgcrypt/libgcrypt_1.4.6.bbappend b/meta-oe/recipes-support/libgcrypt/libgcrypt_1.4.6.bbappend
new file mode 100644
index 000000000..d9172b491
--- /dev/null
+++ b/meta-oe/recipes-support/libgcrypt/libgcrypt_1.4.6.bbappend
@@ -0,0 +1,2 @@
1BBCLASSEXTEND = "native"
2