summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/hdf5/hdf5_1.8.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/hdf5/hdf5_1.8.19.bb')
-rw-r--r--meta-oe/recipes-support/hdf5/hdf5_1.8.19.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/hdf5/hdf5_1.8.19.bb b/meta-oe/recipes-support/hdf5/hdf5_1.8.19.bb
new file mode 100644
index 0000000000..7ea6f6477f
--- /dev/null
+++ b/meta-oe/recipes-support/hdf5/hdf5_1.8.19.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Unique technology suite that makes possible the management of \
2extremely large and complex data collections"
3HOMEPAGE = "https://www.hdfgroup.org/"
4SECTION = "libs"
5
6LICENSE = "HDF5"
7LIC_FILES_CHKSUM = "file://COPYING;md5=57e5351b17591e659eedae107265c606"
8
9inherit cmake
10
11SRC_URI = " \
12 https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.8/hdf5-${PV}/src/${BPN}-${PV}.tar.bz2 \
13 file://H5lib_settings.c \
14 file://H5Tinit.c \
15 file://0001-cross-compiling-support.patch \
16 file://0002-Remove-suffix-shared-from-shared-library-name.patch \
17"
18
19SRC_URI[md5sum] = "6f0353ee33e99089c110a1c8d2dd1b22"
20SRC_URI[sha256sum] = "59c03816105d57990329537ad1049ba22c2b8afe1890085f0c022b75f1727238"
21
22FILES_${PN} += "${libdir}/libhdf5.settings ${datadir}/*"
23
24EXTRA_OECMAKE = " \
25 -DTEST_LFS_WORKS_RUN=0 \
26 -DTEST_LFS_WORKS_RUN__TRYRUN_OUTPUT=0 \
27 -DH5_PRINTF_LL_TEST_RUN=1 \
28 -DH5_PRINTF_LL_TEST_RUN__TRYRUN_OUTPUT='8' \
29 -DH5_LDOUBLE_TO_LONG_SPECIAL_RUN=0 \
30 -DH5_LDOUBLE_TO_LONG_SPECIAL_RUN__TRYRUN_OUTPUT= \
31 -DH5_LONG_TO_LDOUBLE_SPECIAL_RUN=0 \
32 -DH5_LONG_TO_LDOUBLE_SPECIAL_RUN__TRYRUN_OUTPUT= \
33 -DH5_LDOUBLE_TO_LLONG_ACCURATE_RUN=0 \
34 -DH5_LDOUBLE_TO_LLONG_ACCURATE_RUN__TRYRUN_OUTPUT= \
35 -DH5_LLONG_TO_LDOUBLE_CORRECT_RUN=0 \
36 -DH5_LLONG_TO_LDOUBLE_CORRECT_RUN__TRYRUN_OUTPUT= \
37 -DH5_NO_ALIGNMENT_RESTRICTIONS_RUN=0 \
38 -DH5_NO_ALIGNMENT_RESTRICTIONS_RUN__TRYRUN_OUTPUT= \
39 -DCMAKE_INSTALL_PREFIX='${prefix}' \
40"
41
42do_unpack[postfuncs] += "gen_hd5file"
43gen_hd5file() {
44 install -m 544 ${WORKDIR}/H5lib_settings.c ${S}
45 install -m 544 ${WORKDIR}/H5Tinit.c ${S}
46}
47
48do_install_append() {
49 # Used for generating config files on target
50 install -m 755 ${B}/bin/H5detect ${D}${bindir}
51 install -m 755 ${B}/bin/H5make_libsettings ${D}${bindir}
52}
53
54BBCLASSEXTEND = "native"
55
56SRC_DISTRIBUTE_LICENSES += "HDF5"