summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gsoap/gsoap_2.8.134.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/gsoap/gsoap_2.8.134.bb')
-rw-r--r--meta-oe/recipes-support/gsoap/gsoap_2.8.134.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gsoap/gsoap_2.8.134.bb b/meta-oe/recipes-support/gsoap/gsoap_2.8.134.bb
new file mode 100644
index 000000000..5528e87e6
--- /dev/null
+++ b/meta-oe/recipes-support/gsoap/gsoap_2.8.134.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
2for the development of SOAP Web Services and clients."
3SECTION = "devel"
4LICENSE = "GPL-2.0-with-OpenSSL-exception"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4f40a941379143186f9602242c3fb729 \
6 file://GPLv2_license.txt;md5=a33672dbe491b6517750a0389063508b"
7
8SRC_URI = "https://prdownloads.sourceforge.net/${BPN}2/${BPN}_${PV}.zip \
9 file://0001-Provide-strtod_l-signature-on-non-glibc-linux-musl-s.patch"
10SRC_URI[sha256sum] = "63478e555c0ccde0164f055ff605b02805db0abc6712a04bcb14cb617b047218"
11
12inherit autotools
13
14BBCLASSEXTEND = "native"
15
16S = "${WORKDIR}/${BPN}-2.8"
17
18EXTRA_OECONF += "--enable-ipv6 --enable-c-locale"
19PARALLEL_MAKE = ""
20
21EXTRA_OEMAKE:class-target = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
22
23DEPENDS = "openssl zlib flex bison bison-native"
24DEPENDS:append:class-target = " gsoap-native"
25
26do_install:append() {
27 install -d ${D}${libdir}
28 for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
29 do
30 oe_libinstall -C gsoap $lib ${D}${libdir}
31 done
32}
33
34do_install:class-native() {
35 oe_runmake DESTDIR=${D} BINDIR=${D}${bindir} install
36}
37
38FILES:${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
39FILES:${PN} += "${datadir}"
40FILES:${PN}-staticdev = "${libdir}"
41FILES:${PN}-dev = "${includedir}"
42RRECOMMENDS:${PN}-dev = "${PN}-staticdev"