summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gd/gd_2.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/gd/gd_2.3.0.bb')
-rw-r--r--meta-oe/recipes-support/gd/gd_2.3.0.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gd/gd_2.3.0.bb b/meta-oe/recipes-support/gd/gd_2.3.0.bb
new file mode 100644
index 000000000..eec8a05ae
--- /dev/null
+++ b/meta-oe/recipes-support/gd/gd_2.3.0.bb
@@ -0,0 +1,52 @@
1SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.github.io/"
9
10SECTION = "libs"
11LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=8e5bc8627b9494741c905d65238c66b7"
13
14DEPENDS = "freetype libpng jpeg zlib tiff"
15
16SRC_URI = "git://github.com/libgd/libgd.git;branch=master \
17 "
18
19SRCREV = "b079fa06223c3ab862c8f0eea58a968727971988"
20
21S = "${WORKDIR}/git"
22
23inherit autotools binconfig gettext pkgconfig
24
25EXTRA_OECONF += " --disable-rpath \
26 --with-jpeg=${STAGING_LIBDIR}/.. \
27 --with-freetype=yes \
28 --without-fontconfig \
29 --without-webp \
30 --without-xpm \
31 --without-x \
32 "
33
34EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
35
36DEBUG_OPTIMIZATION_append = " -Wno-error=maybe-uninitialized"
37
38do_install_append() {
39 # cleanup buildpaths from gdlib.pc
40 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
41}
42
43PACKAGES += "${PN}-tools"
44
45FILES_${PN} = "${libdir}/lib*${SOLIBS}"
46FILES_${PN}-tools = "${bindir}/*"
47
48PROVIDES += "${PN}-tools"
49RPROVIDES_${PN}-tools = "${PN}-tools"
50RDEPENDS_${PN}-tools = "perl perl-module-strict"
51
52CVE_PRODUCT = "libgd"