summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fuse/fuse3_3.16.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/fuse/fuse3_3.16.2.bb')
-rw-r--r--meta-oe/recipes-support/fuse/fuse3_3.16.2.bb98
1 files changed, 98 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fuse/fuse3_3.16.2.bb b/meta-oe/recipes-support/fuse/fuse3_3.16.2.bb
new file mode 100644
index 000000000..47b070557
--- /dev/null
+++ b/meta-oe/recipes-support/fuse/fuse3_3.16.2.bb
@@ -0,0 +1,98 @@
1SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
2DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
3 programs to export a virtual filesystem to the Linux kernel. FUSE \
4 also aims to provide a secure method for non privileged users to \
5 create and mount their own filesystem implementations. \
6 "
7HOMEPAGE = "https://github.com/libfuse/libfuse"
8SECTION = "libs"
9LICENSE = "GPL-2.0-only & LGPL-2.0-only"
10LIC_FILES_CHKSUM = " \
11 file://GPL2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://LGPL2.txt;md5=4fbd65380cdd255951079008b364516c \
13 file://LICENSE;md5=a55c12a2d7d742ecb41ca9ae0a6ddc66 \
14"
15
16SRC_URI = "https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.gz"
17SRC_URI[sha256sum] = "f797055d9296b275e981f5f62d4e32e089614fc253d1ef2985851025b8a0ce87"
18
19S = "${WORKDIR}/fuse-${PV}"
20
21UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases"
22UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>3(\.\d+)+).tar.xz"
23
24CVE_PRODUCT = "fuse_project:fuse"
25
26inherit meson pkgconfig ptest
27
28SRC_URI += " \
29 file://run-ptest \
30 file://fuse3.conf \
31"
32
33RDEPENDS:${PN}-ptest += " \
34 python3-pytest \
35 python3-looseversion \
36 bash \
37"
38RRECOMMENDS:${PN}-ptest += " kernel-module-cuse"
39
40do_install_ptest() {
41 install -d ${D}${PTEST_PATH}/test
42 install -d ${D}${PTEST_PATH}/example
43 install -d ${D}${PTEST_PATH}/util
44 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
45
46 example_excutables=`find ${B}/example -type f -executable`
47 util_excutables=`find ${B}/util -type f -executable`
48 test_excutables=`find ${B}/test -type f -executable`
49
50 for e in $example_excutables
51 do
52 cp -rf $e ${D}${PTEST_PATH}/example/
53 done
54
55 for e in $util_excutables
56 do
57 cp -rf $e ${D}${PTEST_PATH}/util/
58 done
59
60 for e in $test_excutables
61 do
62 cp -rf $e ${D}${PTEST_PATH}/test
63 done
64}
65
66DEPENDS = "udev"
67
68PACKAGES =+ "fuse3-utils"
69
70RPROVIDES:${PN}-dbg += "fuse3-utils-dbg"
71
72RRECOMMENDS:${PN}:class-target = "kernel-module-fuse fuse3-utils"
73
74FILES:${PN} += "${libdir}/libfuse3.so.*"
75FILES:${PN}-dev += "${libdir}/libfuse3*.la"
76
77# Forbid auto-renaming to libfuse3-utils
78FILES:fuse3-utils = "${bindir} ${base_sbindir}"
79DEBIAN_NOAUTONAME:fuse3-utils = "1"
80DEBIAN_NOAUTONAME:${PN}-dbg = "1"
81
82SYSTEMD_SERVICE:${PN} = ""
83
84do_install:append() {
85 rm -rf ${D}${base_prefix}/dev
86
87 # systemd class remove the sysv_initddir only if systemd_system_unitdir
88 # contains anything, but it's not needed if sysvinit is not in DISTRO_FEATURES
89 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'false', 'true', d)}; then
90 rm -rf ${D}${sysconfdir}/init.d/
91 fi
92
93 # Install systemd related configuration file
94 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
95 install -d ${D}${sysconfdir}/modules-load.d
96 install -m 0644 ${UNPACKDIR}/fuse3.conf ${D}${sysconfdir}/modules-load.d
97 fi
98}