diff options
Diffstat (limited to 'meta-oe/recipes-support/freerdp/freerdp_2.8.1.bb')
-rw-r--r-- | meta-oe/recipes-support/freerdp/freerdp_2.8.1.bb | 85 |
1 files changed, 85 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/freerdp/freerdp_2.8.1.bb b/meta-oe/recipes-support/freerdp/freerdp_2.8.1.bb new file mode 100644 index 000000000..5f539671b --- /dev/null +++ b/meta-oe/recipes-support/freerdp/freerdp_2.8.1.bb | |||
@@ -0,0 +1,85 @@ | |||
1 | # Copyright (C) 2010-2012 O.S. Systems Software Ltda. All Rights Reserved | ||
2 | # Released under the MIT license | ||
3 | |||
4 | DESCRIPTION = "FreeRDP RDP client & server library" | ||
5 | HOMEPAGE = "http://www.freerdp.com" | ||
6 | DEPENDS = "openssl alsa-lib libusb1" | ||
7 | SECTION = "net" | ||
8 | LICENSE = "Apache-2.0" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
10 | |||
11 | inherit pkgconfig cmake gitpkgv | ||
12 | |||
13 | PE = "1" | ||
14 | PKGV = "${GITPKGVTAG}" | ||
15 | |||
16 | SRCREV = "0ad3f49f0e7eb78586acc6bf6e4605f96f88954e" | ||
17 | SRC_URI = "git://github.com/FreeRDP/FreeRDP.git;branch=stable-2.0;protocol=https \ | ||
18 | file://winpr-makecert-Build-with-install-RPATH.patch \ | ||
19 | " | ||
20 | |||
21 | S = "${WORKDIR}/git" | ||
22 | |||
23 | EXTRA_OECMAKE += " \ | ||
24 | -DWITH_ALSA=ON \ | ||
25 | -DWITH_FFMPEG=OFF \ | ||
26 | -DWITH_CUNIT=OFF \ | ||
27 | -DWITH_NEON=OFF \ | ||
28 | -DBUILD_STATIC_LIBS=OFF \ | ||
29 | -DCMAKE_POSITION_INDEPENDANT_CODE=ON \ | ||
30 | -DWITH_MANPAGES=OFF \ | ||
31 | " | ||
32 | |||
33 | PACKAGECONFIG ??= " \ | ||
34 | ${@bb.utils.filter('DISTRO_FEATURES', 'directfb pam pulseaudio wayland x11', d)}\ | ||
35 | gstreamer cups pcsc \ | ||
36 | " | ||
37 | |||
38 | X11_DEPS = "virtual/libx11 libxinerama libxext libxcursor libxv libxi libxrender libxfixes libxdamage libxrandr libxkbfile" | ||
39 | PACKAGECONFIG[x11] = "-DWITH_X11=ON -DWITH_XINERAMA=ON -DWITH_XEXT=ON -DWITH_XCURSOR=ON -DWITH_XV=ON -DWITH_XI=ON -DWITH_XRENDER=ON -DWITH_XFIXES=ON -DWITH_XDAMAGE=ON -DWITH_XRANDR=ON -DWITH_XKBFILE=ON,-DWITH_X11=OFF,${X11_DEPS}" | ||
40 | PACKAGECONFIG[wayland] = "-DWITH_WAYLAND=ON,-DWITH_WAYLAND=OFF,wayland wayland-native libxkbcommon" | ||
41 | PACKAGECONFIG[directfb] = "-DWITH_DIRECTFB=ON,-DWITH_DIRECTFB=OFF,directfb" | ||
42 | PACKAGECONFIG[pam] = "-DWITH_PAM=ON,-DWITH_PAM=OFF,libpam" | ||
43 | PACKAGECONFIG[pcsc] = "-DWITH_PCSC=ON,-DWITH_PCSC=OFF,pcsc-lite" | ||
44 | PACKAGECONFIG[pulseaudio] = "-DWITH_PULSEAUDIO=ON,-DWITH_PULSEAUDIO=OFF,pulseaudio" | ||
45 | PACKAGECONFIG[gstreamer] = "-DWITH_GSTREAMER_1_0=ON,-DWITH_GSTREAMER_1_0=OFF,gstreamer1.0 gstreamer1.0-plugins-base" | ||
46 | PACKAGECONFIG[cups] = "-DWITH_CUPS=ON,-DWITH_CUPS=OFF,cups" | ||
47 | |||
48 | PACKAGES =+ "libfreerdp" | ||
49 | |||
50 | LEAD_SONAME = "libfreerdp.so" | ||
51 | FILES:libfreerdp = "${libdir}/lib*${SOLIBS}" | ||
52 | |||
53 | PACKAGES_DYNAMIC += "^libfreerdp-plugin-.*" | ||
54 | |||
55 | # we will need winpr-makecert to generate TLS certificates | ||
56 | do_install:append () { | ||
57 | install -d ${D}${bindir} | ||
58 | install -m755 winpr/tools/makecert-cli/winpr-makecert ${D}${bindir} | ||
59 | rm -rf ${D}${libdir}/cmake | ||
60 | rm -rf ${D}${libdir}/freerdp | ||
61 | } | ||
62 | |||
63 | python populate_packages:prepend () { | ||
64 | freerdp_root = d.expand('${libdir}/freerdp') | ||
65 | |||
66 | do_split_packages(d, freerdp_root, r'^(audin_.*)\.so$', | ||
67 | output_pattern='libfreerdp-plugin-%s', | ||
68 | description='FreeRDP plugin %s', | ||
69 | prepend=True, extra_depends='libfreerdp-plugin-audin') | ||
70 | |||
71 | do_split_packages(d, freerdp_root, r'^(rdpsnd_.*)\.so$', | ||
72 | output_pattern='libfreerdp-plugin-%s', | ||
73 | description='FreeRDP plugin %s', | ||
74 | prepend=True, extra_depends='libfreerdp-plugin-rdpsnd') | ||
75 | |||
76 | do_split_packages(d, freerdp_root, r'^(tsmf_.*)\.so$', | ||
77 | output_pattern='libfreerdp-plugin-%s', | ||
78 | description='FreeRDP plugin %s', | ||
79 | prepend=True, extra_depends='libfreerdp-plugin-tsmf') | ||
80 | |||
81 | do_split_packages(d, freerdp_root, r'^([^-]*)\.so$', | ||
82 | output_pattern='libfreerdp-plugin-%s', | ||
83 | description='FreeRDP plugin %s', | ||
84 | prepend=True, extra_depends='') | ||
85 | } | ||