summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fltk/fltk.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/fltk/fltk.bb')
-rw-r--r--meta-oe/recipes-support/fltk/fltk.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk.bb b/meta-oe/recipes-support/fltk/fltk.bb
new file mode 100644
index 000000000..542fd661e
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk.bb
@@ -0,0 +1,34 @@
1require ${BPN}.inc
2
3DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft ${BPN}-native"
4
5inherit binconfig lib_package gtk-icon-cache mime
6
7EXTRA_OECMAKE = " \
8 -DOPTION_BUILD_SHARED_LIBS=ON \
9 -DOPTION_USE_THREADS=ON \
10 -DOPTION_USE_XDBE=ON \
11 -DOPTION_USE_XFT=ON \
12 -DFLTK_CONFIG_PATH=${libdir}/cmake \
13"
14
15PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
16
17PACKAGECONFIG[examples] = "-DOPTION_BUILD_EXAMPLES=ON,-DOPTION_BUILD_EXAMPLES=OFF,"
18PACKAGECONFIG[opengl] = "-DOPTION_USE_GL=ON,-DOPTION_USE_GL=OFF,virtual/libgl"
19PACKAGECONFIG[xinerama] = "-DOPTION_USE_XINERAMA=ON,-DOPTION_USE_XINERAMA=OFF,libxinerama"
20PACKAGECONFIG[xfixes] = "-DOPTION_USE_XFIXES=ON,-DOPTION_USE_XFIXES=OFF,libxfixes"
21PACKAGECONFIG[xcursor] = "-DOPTION_USE_XCURSOR=ON,-DOPTION_USE_XCURSOR=OFF,libxcursor"
22
23do_install_append() {
24 sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/fltk-config
25}
26
27python populate_packages_prepend () {
28 if (d.getVar('DEBIAN_NAMES')):
29 d.setVar('PKG_${BPN}', 'libfltk${PV}')
30}
31
32LEAD_SONAME = "libfltk.so"
33
34FILES_${PN} += "${datadir}/mime"